aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-10-15 12:52:34 +0200
committerFelix Fietkau <nbd@nbd.name>2019-08-12 11:43:39 +0200
commitb1db6d0539511f60bf65fbde28b16afa31180e34 (patch)
treef536cf119296e3a5f16fd5c5cc06037d606f1842 /target/linux/ramips/image/mt7621.mk
parent363ce4329d4f6c00b4a7cb83dd1821fafc0d40ad (diff)
downloadupstream-b1db6d0539511f60bf65fbde28b16afa31180e34.tar.gz
upstream-b1db6d0539511f60bf65fbde28b16afa31180e34.tar.bz2
upstream-b1db6d0539511f60bf65fbde28b16afa31180e34.zip
ramips: add preliminary support for SGE AP-MTKH7-0006 developer board
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d32feb7eab..eeda908c44 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -685,6 +685,17 @@ define Device/xzwifi_creativebox-v1
endef
TARGET_DEVICES += xzwifi_creativebox-v1
+define Device/ap-mtkh7-0006
+ DTS := AP-MTKH7-0006
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ SUPPORTED_DEVICES := sge,ap-mtkh7-0006
+ DEVICE_TITLE := SGE AP-MTKH7-0006
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+ kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += ap-mtkh7-0006
+
define Device/youhua_wr1200js
MTK_SOC := mt7621
IMAGE_SIZE := 16064k