aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-11-12 01:25:31 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 19:42:48 +0100
commita972b1fb5f5d5c159b0310b3623cfd5442a5c322 (patch)
tree1f745a868728166c15235a31fa9fd4eab5c93fb5 /target/linux/ramips/image/mt7621.mk
parent5cda133d99f25ac85fcc4ef9ae092f9c4fb90739 (diff)
downloadupstream-a972b1fb5f5d5c159b0310b3623cfd5442a5c322.tar.gz
upstream-a972b1fb5f5d5c159b0310b3623cfd5442a5c322.tar.bz2
upstream-a972b1fb5f5d5c159b0310b3623cfd5442a5c322.zip
ramips: add support for ipTIME A6ns-M
ipTIME A6ns-M is a 2.4/5GHz band AC1900 router, based on MediaTek MT7621A. Specifications: - SoC: MT7621AT - RAM: DDR3 128MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: MT7615 - 5GHz: MT7615 - Ethernet: 5x 10/100/1000Mbps - Switch: SoC internal - UART: - J4: 3.3V, TX, RX, GND (3.3V is the square pad) / 57600 8N1 Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware: 1. Perform sysupgrade with stock image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0b2b74800a..5b1c4b7321 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -361,6 +361,16 @@ define Device/iodata_wnpr2600g
endef
TARGET_DEVICES += iodata_wnpr2600g
+define Device/iptime_a6ns-m
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16128k
+ UIMAGE_NAME := a6nm
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := A6ns-M
+ DEVICE_PACKAGES := kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += iptime_a6ns-m
+
define Device/lenovo_newifi-d1
MTK_SOC := mt7621
IMAGE_SIZE := 32448k