aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorQi Jiang <rushx@live.cn>2019-09-08 09:52:07 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-09-25 14:44:36 +0800
commit93b6cc97ca9694434faef69c6c5145b5dc7c1ae4 (patch)
tree473e82ddc6137c2738619536d48d2de6e9befa0c /target/linux/ramips/image/mt7621.mk
parente39d1cf34f97667b8fc1cdb60beec7a12e70839d (diff)
downloadupstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.tar.gz
upstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.tar.bz2
upstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.zip
ramips: add support for XiaoYu XY-C5
Hardware: SoC: MT7621A Flash: 32 MiB RAM: 512 MiB Ethernet: built-in switch USB: 1x USB3.0 SATA: ASM1060, 1 SATA port Flash instruction (TFTP): 1. Set PC to fixed ip address 192.168.173.22 2. Download *-sysupgrade.bin image and rename it to firmware.img 3. Start a tftp server with the image file in its root directory 4. Turn off the router 5. Turn on router,press the reset button and wait ~15 seconds 6. Release the reset button and after a short time the firmware should be transferred from the tftp server 7. Wait ~3 minutes to complete recovery. Signed-off-by: Qi Jiang <rushx@live.cn> [squash commits, add label-mac-device, fix sign-off style] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f098976dfc..644f984197 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -768,6 +768,15 @@ define Device/xiaomi_mir3p
endef
TARGET_DEVICES += xiaomi_mir3p
+define Device/xiaoyu_xy-c5
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := XiaoYu
+ DEVICE_MODEL := XY-C5
+ DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3
+endef
+TARGET_DEVICES += xiaoyu_xy-c5
+
define Device/xzwifi_creativebox-v1
MTK_SOC := mt7621
IMAGE_SIZE := 32448k