aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2019-08-29 10:08:38 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-31 10:31:00 +0200
commit6cea9688af4a05f407266ed1de5a739e5c984b8c (patch)
tree8d51ac01326a7bec0ce2c775834c9a40eb8d12bd /target/linux/ramips/image/mt7621.mk
parent3c8df280a96bbd81357d6eb52845e6b5fa7162fe (diff)
downloadupstream-6cea9688af4a05f407266ed1de5a739e5c984b8c.tar.gz
upstream-6cea9688af4a05f407266ed1de5a739e5c984b8c.tar.bz2
upstream-6cea9688af4a05f407266ed1de5a739e5c984b8c.zip
ramips: add support for Netgear R6260 and R6850
As Netgear uses the same image for R6260, R6350 & R6850 we can merge device tree files and generate separate images for each device. Signed-off-by: Christoph Krapp <achterin@googlemail.com> [add missing WiFi compatible string, fix network configuration] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 96dd74afcf..986fe5e2f8 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -414,7 +414,7 @@ define Device/netgear_r6220
endef
TARGET_DEVICES += netgear_r6220
-define Device/netgear_r6350
+define Device/netgear_r6260_r6350_r6850
MTK_SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
@@ -431,12 +431,28 @@ define Device/netgear_r6350
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
DEVICE_VENDOR := NETGEAR
- DEVICE_MODEL := R6350
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
endef
+
+define Device/netgear_r6260
+ $(Device/netgear_r6260_r6350_r6850)
+ DEVICE_MODEL := R6260
+endef
+TARGET_DEVICES += netgear_r6260
+
+define Device/netgear_r6350
+ $(Device/netgear_r6260_r6350_r6850)
+ DEVICE_MODEL := R6350
+endef
TARGET_DEVICES += netgear_r6350
+define Device/netgear_r6850
+ $(Device/netgear_r6260_r6350_r6850)
+ DEVICE_MODEL := R6850
+endef
+TARGET_DEVICES += netgear_r6850
+
define Device/netgear_wndr3700-v5
MTK_SOC := mt7621
BLOCKSIZE := 64k