aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorMaksym Medvedev <redrathnure@gmail.com>2019-11-15 23:21:22 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-04 16:49:59 +0100
commit663b1a14e59074a23b86237e0b13dc6e78a6e50b (patch)
treed9a10ef4fd2456c70ef565792cff0c36149160ad /target/linux/ramips/image/mt7621.mk
parentf64c64a91c86e07a9d34ff268df77b9625e11bd1 (diff)
downloadupstream-663b1a14e59074a23b86237e0b13dc6e78a6e50b.tar.gz
upstream-663b1a14e59074a23b86237e0b13dc6e78a6e50b.tar.bz2
upstream-663b1a14e59074a23b86237e0b13dc6e78a6e50b.zip
ramips: add support for Edimax RA21S
Edimax RA21S is a dual band 11ac router, based on MediaTek MT7621A and MT7615N chips. Specification: - SoC: MediaTek MT7621A dual-core @ 880MHz - RAM: 256M (Nanya NT5CC128M16IP) - FLASH: 16MB (Macronix MX25L12835F) - WiFi: 2.4/5 GHz 4T4R - 2.4GHz MediaTek MT7615N bgn - 5GHz MediaTek MT7615N nac - Switch: SoC integrated Gigabit Switch (4 x LAN, 1 x WAN) - USB: No - BTN: Reset, WPS - LED: 4 red LEDs, indistinguishable when case closed - UART: through-hole on PCB. J1: 3.3V - RX - GND - TX / 57600-8N1. 3.3V is the square pad Installation: Update the factory image via the OEM web-interface (by default: http://192.168.2.1/) User: admin Password: 1234 The sysupgrade image can be installed via TFTP from the U-Boot bootloader. Connect via ethernet port 2. Tested on device by @UAb5eSMn Signed-off-by: Maksym Medvedev <redrathnure@gmail.com> [split DTS and take over improvements from RG21S, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index c0706f7998..b33c2c5bc0 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -224,6 +224,20 @@ define Device/d-team_pbr-m1
endef
TARGET_DEVICES += d-team_pbr-m1
+define Device/edimax_ra21s
+ SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := Edimax
+ DEVICE_MODEL := RA21S
+ DEVICE_ALT0_VENDOR := Edimax
+ DEVICE_ALT0_MODEL := Gemini RA21S
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ elx-header 02020040 8844A2D168B45A2D
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += edimax_ra21s
+
define Device/edimax_rg21s
SOC := mt7621
IMAGE_SIZE := 16064k