aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:15:57 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-20 01:15:57 +0100
commit58e71e322bc0e0edd08157075e9022c15ae33ec5 (patch)
tree4d8f529a68db84b6c2ed19991e3eabc994cadab4 /target/linux/ramips/image/mt7621.mk
parent95030ac0b673165772daf27128359eaaf536d457 (diff)
downloadupstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.tar.gz
upstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.tar.bz2
upstream-58e71e322bc0e0edd08157075e9022c15ae33ec5.zip
ramips: rename MTK_SOC to SOC
This replaces MTK_SOC by the newly introduced common SOC device variable. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk128
1 files changed, 64 insertions, 64 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 0b178a8d6e..c0706f7998 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -85,7 +85,7 @@ define Build/wr1201-factory-header
endef
define Device/afoundry_ew1200
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := AFOUNDRY
DEVICE_MODEL := EW1200
@@ -96,7 +96,7 @@ endef
TARGET_DEVICES += afoundry_ew1200
define Device/alfa-network_quad-e4g
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := ALFA Network
DEVICE_MODEL := Quad-E4G
@@ -106,7 +106,7 @@ endef
TARGET_DEVICES += alfa-network_quad-e4g
define Device/asiarf_ap7621-001
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16000k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AP7621-001
@@ -115,7 +115,7 @@ endef
TARGET_DEVICES += asiarf_ap7621-001
define Device/asiarf_ap7621-nv1
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16000k
DEVICE_VENDOR := AsiaRF
DEVICE_MODEL := AP7621-NV1
@@ -124,7 +124,7 @@ endef
TARGET_DEVICES += asiarf_ap7621-nv1
define Device/asus_rt-ac57u
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC57U
IMAGE_SIZE := 16064k
@@ -134,7 +134,7 @@ endef
TARGET_DEVICES += asus_rt-ac57u
define Device/asus_rt-ac65p
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC65P
IMAGE_SIZE := 51200k
@@ -151,7 +151,7 @@ endef
TARGET_DEVICES += asus_rt-ac65p
define Device/asus_rt-ac85p
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-AC85P
IMAGE_SIZE := 51200k
@@ -168,7 +168,7 @@ endef
TARGET_DEVICES += asus_rt-ac85p
define Device/buffalo_wsr-1166dhp
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata
IMAGE_SIZE := 15936k
DEVICE_VENDOR := Buffalo
@@ -179,7 +179,7 @@ endef
TARGET_DEVICES += buffalo_wsr-1166dhp
define Device/buffalo_wsr-600dhp
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WSR-600DHP
@@ -190,7 +190,7 @@ TARGET_DEVICES += buffalo_wsr-600dhp
define Device/dlink_dir-860l-b1
$(Device/seama)
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 64k
SEAMA_SIGNATURE := wrgac13_dlink.2013gui_dir860lb
KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma | uImage lzma
@@ -204,7 +204,7 @@ endef
TARGET_DEVICES += dlink_dir-860l-b1
define Device/d-team_newifi-d2
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Newifi
DEVICE_MODEL := D2
@@ -214,7 +214,7 @@ endef
TARGET_DEVICES += d-team_newifi-d2
define Device/d-team_pbr-m1
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := PandoraBox
DEVICE_MODEL := PBR-M1
@@ -225,7 +225,7 @@ endef
TARGET_DEVICES += d-team_pbr-m1
define Device/edimax_rg21s
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Edimax
DEVICE_MODEL := Gemini AC2600 RG21S
@@ -237,7 +237,7 @@ endef
TARGET_DEVICES += edimax_rg21s
define Device/elecom_wrc-1167ghbk2-s
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 15488k
DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-1167GHBK2-S
@@ -249,7 +249,7 @@ endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
define Device/elecom_wrc-1900gst
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 11264k
DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-1900GST
@@ -260,7 +260,7 @@ endef
TARGET_DEVICES += elecom_wrc-1900gst
define Device/elecom_wrc-2533gst
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 11264k
DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-2533GST
@@ -271,7 +271,7 @@ endef
TARGET_DEVICES += elecom_wrc-2533gst
define Device/firefly_firewrt
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Firefly
DEVICE_MODEL := FireWRT
@@ -281,7 +281,7 @@ endef
TARGET_DEVICES += firefly_firewrt
define Device/gehua_ghl-r-001
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := GeHua
DEVICE_MODEL := GHL-R-001
@@ -291,7 +291,7 @@ endef
TARGET_DEVICES += gehua_ghl-r-001
define Device/gnubee_gb-pc1
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := GnuBee
DEVICE_MODEL := Personal Cloud One
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
@@ -300,7 +300,7 @@ endef
TARGET_DEVICES += gnubee_gb-pc1
define Device/gnubee_gb-pc2
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := GnuBee
DEVICE_MODEL := Personal Cloud Two
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620
@@ -309,7 +309,7 @@ endef
TARGET_DEVICES += gnubee_gb-pc2
define Device/hiwifi_hc5962
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 2097152
@@ -327,7 +327,7 @@ endef
TARGET_DEVICES += hiwifi_hc5962
define Device/iodata_wn-ax1167gr
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 15552k
KERNEL_INITRAMFS := $$(KERNEL) | \
iodata-factory 7864320 4 0x1055 $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.bin
@@ -338,7 +338,7 @@ endef
TARGET_DEVICES += iodata_wn-ax1167gr
define Device/iodata_wn-gx300gr
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 7616k
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-GX300GR
@@ -347,7 +347,7 @@ endef
TARGET_DEVICES += iodata_wn-gx300gr
define Device/iodata_wnpr2600g
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WNPR2600G
IMAGE_SIZE := 13952k
@@ -359,7 +359,7 @@ endef
TARGET_DEVICES += iodata_wnpr2600g
define Device/iptime_a6ns-m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16128k
UIMAGE_NAME := a6nm
DEVICE_VENDOR := ipTIME
@@ -369,7 +369,7 @@ endef
TARGET_DEVICES += iptime_a6ns-m
define Device/jcg_jhr-ac876m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
@@ -382,7 +382,7 @@ endef
TARGET_DEVICES += jcg_jhr-ac876m
define Device/lenovo_newifi-d1
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Newifi
DEVICE_MODEL := D1
@@ -393,7 +393,7 @@ endef
TARGET_DEVICES += lenovo_newifi-d1
define Device/linksys_re6500
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Linksys
DEVICE_MODEL := RE6500
@@ -403,7 +403,7 @@ endef
TARGET_DEVICES += linksys_re6500
define Device/mediatek_ap-mt7621a-v60
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Mediatek
DEVICE_MODEL := AP-MT7621A-V60 EVB
@@ -412,7 +412,7 @@ endef
TARGET_DEVICES += mediatek_ap-mt7621a-v60
define Device/mediatek_mt7621-eval-board
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 64k
IMAGE_SIZE := 15104k
DEVICE_VENDOR := MediaTek
@@ -422,7 +422,7 @@ endef
TARGET_DEVICES += mediatek_mt7621-eval-board
define Device/MikroTik
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := MikroTik
BLOCKSIZE := 64k
IMAGE_SIZE := 16128k
@@ -456,7 +456,7 @@ endef
TARGET_DEVICES += mikrotik_rbm33g
define Device/mqmaker_witi
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := MQmaker
DEVICE_MODEL := WiTi
@@ -467,7 +467,7 @@ endef
TARGET_DEVICES += mqmaker_witi
define Device/mtc_wr1201
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16000k
DEVICE_VENDOR := MTC
DEVICE_MODEL := Wireless Router WR1201
@@ -478,7 +478,7 @@ endef
TARGET_DEVICES += mtc_wr1201
define Device/netgear_ex6150
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := EX6150
DEVICE_PACKAGES := kmod-mt76x2 wpad-basic
@@ -491,7 +491,7 @@ endef
TARGET_DEVICES += netgear_ex6150
define Device/netgear_sercomm_nand
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
@@ -559,7 +559,7 @@ endef
TARGET_DEVICES += netgear_r6850
define Device/netgear_wndr3700-v5
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 64k
IMAGE_SIZE := 15232k
SERCOMM_HWID := AYB
@@ -583,7 +583,7 @@ endef
TARGET_DEVICES += netgear_wndr3700-v5
define Device/netis_wf-2881
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
FILESYSTEMS := squashfs
@@ -600,7 +600,7 @@ endef
TARGET_DEVICES += netis_wf-2881
define Device/phicomm_k2p
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 15744k
DEVICE_VENDOR := Phicomm
DEVICE_MODEL := K2P
@@ -612,7 +612,7 @@ endef
TARGET_DEVICES += phicomm_k2p
define Device/planex_vr500
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 65216k
DEVICE_VENDOR := Planex
DEVICE_MODEL := VR500
@@ -622,7 +622,7 @@ endef
TARGET_DEVICES += planex_vr500
define Device/samknows_whitebox-v8
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := SamKnows
DEVICE_MODEL := Whitebox 8
@@ -633,7 +633,7 @@ endef
TARGET_DEVICES += samknows_whitebox-v8
define Device/storylink_sap-g3200u3
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 7872k
DEVICE_VENDOR := STORYLiNK
DEVICE_MODEL := SAP-G3200U3
@@ -643,7 +643,7 @@ endef
TARGET_DEVICES += storylink_sap-g3200u3
define Device/telco-electronics_x1
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Telco Electronics
DEVICE_MODEL := X1
@@ -652,7 +652,7 @@ endef
TARGET_DEVICES += telco-electronics_x1
define Device/thunder_timecloud
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Thunder
DEVICE_MODEL := Timecloud
@@ -662,7 +662,7 @@ endef
TARGET_DEVICES += thunder_timecloud
define Device/totolink_a7000r
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
UIMAGE_NAME := C8340R1C-9999
DEVICE_VENDOR := TOTOLINK
@@ -672,7 +672,7 @@ endef
TARGET_DEVICES += totolink_a7000r
define Device/adslr_g7
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := ADSLR
DEVICE_MODEL := G7
@@ -681,7 +681,7 @@ endef
TARGET_DEVICES += adslr_g7
define Device/tplink-safeloader
- MTK_SOC := mt7621
+ SOC := mt7621
DEVICE_VENDOR := TP-Link
TPLINK_BOARD_ID :=
TPLINK_HWID := 0x0
@@ -716,7 +716,7 @@ endef
TARGET_DEVICES += tplink_re650-v1
define Device/ubiquiti_edgerouterx
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 256768k
FILESYSTEMS := squashfs
KERNEL_SIZE := 3145728
@@ -739,7 +739,7 @@ endef
TARGET_DEVICES += ubiquiti_edgerouterx-sfp
define Device/unielec_u7621-06-16m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
@@ -750,7 +750,7 @@ endef
TARGET_DEVICES += unielec_u7621-06-16m
define Device/unielec_u7621-06-64m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 65216k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
@@ -761,7 +761,7 @@ endef
TARGET_DEVICES += unielec_u7621-06-64m
define Device/wevo_11acnas
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
DEVICE_VENDOR := WeVO
@@ -773,7 +773,7 @@ endef
TARGET_DEVICES += wevo_11acnas
define Device/wevo_w2914ns-v2
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
UIMAGE_NAME := W2914NS-V2(0.0.0)
DEVICE_VENDOR := WeVO
@@ -786,7 +786,7 @@ endef
TARGET_DEVICES += wevo_w2914ns-v2
define Device/xiaomi_mir3g
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE := 4096k
@@ -806,7 +806,7 @@ endef
TARGET_DEVICES += xiaomi_mir3g
define Device/xiaomi_mir3g-v2
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 14848k
DEVICE_VENDOR := Xiaomi
DEVICE_MODEL := Mi Router 3G
@@ -819,7 +819,7 @@ endef
TARGET_DEVICES += xiaomi_mir3g-v2
define Device/xiaomi_mir3p
- MTK_SOC := mt7621
+ SOC := mt7621
BLOCKSIZE := 128k
PAGESIZE := 2048
KERNEL_SIZE:= 4096k
@@ -837,7 +837,7 @@ endef
TARGET_DEVICES += xiaomi_mir3p
define Device/xiaoyu_xy-c5
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := XiaoYu
DEVICE_MODEL := XY-C5
@@ -846,7 +846,7 @@ endef
TARGET_DEVICES += xiaoyu_xy-c5
define Device/xzwifi_creativebox-v1
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := CreativeBox
DEVICE_MODEL := v1
@@ -856,7 +856,7 @@ endef
TARGET_DEVICES += xzwifi_creativebox-v1
define Device/youhua_wr1200js
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := YouHua
DEVICE_MODEL := WR1200JS
@@ -866,7 +866,7 @@ endef
TARGET_DEVICES += youhua_wr1200js
define Device/youku_yk-l2
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Youku
DEVICE_MODEL := YK-L2
@@ -876,7 +876,7 @@ endef
TARGET_DEVICES += youku_yk-l2
define Device/zbtlink_zbt-we1326
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WE1326
@@ -887,7 +887,7 @@ endef
TARGET_DEVICES += zbtlink_zbt-we1326
define Device/zbtlink_zbt-we3526
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WE3526
@@ -897,7 +897,7 @@ endef
TARGET_DEVICES += zbtlink_zbt-we3526
define Device/zbtlink_zbt-wg2626
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG2626
@@ -908,7 +908,7 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg2626
define Device/zbtlink_zbt-wg3526-16m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG3526
@@ -920,7 +920,7 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-16m
define Device/zbtlink_zbt-wg3526-32m
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 32448k
DEVICE_VENDOR := Zbtlink
DEVICE_MODEL := ZBT-WG3526
@@ -932,7 +932,7 @@ endef
TARGET_DEVICES += zbtlink_zbt-wg3526-32m
define Device/zio_freezio
- MTK_SOC := mt7621
+ SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := ZIO
DEVICE_MODEL := FREEZIO