aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2019-12-11 21:54:24 +0100
committerDavid Bauer <mail@david-bauer.net>2020-03-04 23:02:46 +0100
commit4e9317201d3fb47800b387d69d79c00f38d2dbfd (patch)
tree0c5f9b7295b19b4225be991f6d90dd1aabb53356 /target/linux/ramips/image/mt7621.mk
parent3251ac8f2d3de29af2a1584f427246ea702fdbd9 (diff)
downloadupstream-4e9317201d3fb47800b387d69d79c00f38d2dbfd.tar.gz
upstream-4e9317201d3fb47800b387d69d79c00f38d2dbfd.tar.bz2
upstream-4e9317201d3fb47800b387d69d79c00f38d2dbfd.zip
ramips: mt7621: add support for Netgear R6800
This patch adds support for the Netgear R6800, aka Netgear AC1900 and R6800-100PES. Specification: - SoC: MediaTek MT7621AT (880 MHz) - Flash: 128 MiB NAND - RAM: 256 MiB - Wireless: MediaTek MT7615EN b/g/n , MediaTek MT7615EN an+ac - LAN speed: 10/100/1000 - LAN ports: 4 - WAN speed: 10/100/1000 - WAN ports: 1 - USB 2.0 - USB 3.0 - Serial baud rate of Bootloader and factory firmware: 57600 Known issues: - Device has 3 wifi LEDs: Wifi 5Ghz, Wifi 2.4Ghz and Wifi on/off. Wifi on/off is not used. Installation: - apply factory image via stock web-gui. Back to stock: - nmrpflash can be used to recover to the stock Netgear firmware. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 4c27cdbd31..82fbd87df9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -595,6 +595,18 @@ define Device/netgear_r6350
endef
TARGET_DEVICES += netgear_r6350
+define Device/netgear_r6800
+ $(Device/netgear_sercomm_nand)
+ DEVICE_MODEL := R6800
+ SERCOMM_HWNAME := R6950
+ SERCOMM_HWID := BZV
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x0062
+ IMAGE_SIZE := 40960k
+ DEVICE_PACKAGES += kmod-mt7615e
+endef
+TARGET_DEVICES += netgear_r6800
+
define Device/netgear_r6850
$(Device/netgear_sercomm_nand)
DEVICE_MODEL := R6850