aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-03-08 21:39:19 +0100
committerDavid Bauer <mail@david-bauer.net>2020-03-10 21:54:46 +0100
commit4c8446bf39de99990847eb4bc7744e25835a34f5 (patch)
tree8315c46efcb3a698533c22f8cedaf4a0825c7eb3 /target/linux/ramips/image/mt7621.mk
parent0c4d91f121b7a3660dbf433a8a6858573a86d137 (diff)
downloadupstream-4c8446bf39de99990847eb4bc7744e25835a34f5.tar.gz
upstream-4c8446bf39de99990847eb4bc7744e25835a34f5.tar.bz2
upstream-4c8446bf39de99990847eb4bc7744e25835a34f5.zip
ramips: add support for Ubiquiti UniFi nanoHD
Hardware -------- SoC: MediaTek MT7621AT WiFi: MediaTek MT7603 bgn 2T2R MediaTek MT7615 ac 4T4R Flash: 32M SPI (Macronix MX25L25635F) RAM: 128M DDR3 (Winbond W631GG6KB) LED: Dome (Blue / White) BTN: Reset Installation ------------ These instructions were written for firmware version v3.9.27. Downgrade if necessary. 1. Copy the OpenWrt sysupgrade image to the devices /tmp folder via scp. On factory defaults, user and password is "ubnt" at 192.168.1.20/24. 2. Write the bootselect flag. Otherwise, the device might boot from the wrong partition. Verify the mtd partition used in the command below is the one labled "bs" in /proc/mtd (as this might change in the future). > dd if=/dev/zero bs=1 count=1 of=/dev/mtd4 3. Write the OpenWrt sysupgrade to the mtd partitions labled "kernel0" and "kernel1". > dd if=/tmp/openwrt-sysupgrade.bin of=/dev/mtdblock6 > dd if=/tmp/openwrt-sysupgrade.bin of=/dev/mtdblock7 4. Reboot or powercycle the device. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 98d83f944f..f24830bfb7 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -792,6 +792,14 @@ define Device/ubiquiti_edgerouterx-sfp
endef
TARGET_DEVICES += ubiquiti_edgerouterx-sfp
+define Device/ubnt_unifi-nanohd
+ DEVICE_VENDOR := Ubiquiti
+ DEVICE_MODEL := UniFi nanoHD
+ DEVICE_PACKAGES += kmod-mt7603 kmod-mt7615e wpad-basic
+ IMAGE_SIZE := 15552k
+endef
+TARGET_DEVICES += ubnt_unifi-nanohd
+
define Device/unielec_u7621-06-16m
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec