aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-17 13:02:26 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-19 11:24:10 +0100
commit478f1f6b167c6b1c91f5915e9567814350865c4c (patch)
tree7364b56ac1a97444c80d3a0f5245707989361f7e /target/linux/ramips/image/mt7621.mk
parentbe296745f82665272771e1cfeb2c19438cf3cb5a (diff)
downloadupstream-478f1f6b167c6b1c91f5915e9567814350865c4c.tar.gz
upstream-478f1f6b167c6b1c91f5915e9567814350865c4c.tar.bz2
upstream-478f1f6b167c6b1c91f5915e9567814350865c4c.zip
ramips: append metadata to images
metadata checks are not enforced yet, because some images are still being built by legacy code Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 04b06ecc16..647df7a12e 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -49,7 +49,7 @@ TARGET_DEVICES += re6500
define Device/wsr-1166
DTS := WSR-1166
- IMAGE/sysupgrade.bin := trx | pad-rootfs
+ IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_TITLE := Buffalo WSR-1166
endef
@@ -64,7 +64,7 @@ define Device/dir-860l-b1
IMAGE/sysupgrade.bin := \
append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
IMAGE/factory.bin := \
append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
append-rootfs | pad-rootfs -x 64 | \
@@ -164,7 +164,7 @@ define Device/wf-2881
IMAGE_SIZE := 129280k
KERNEL := $(KERNEL_DTB) | pad-offset $$(BLOCKSIZE) 64 | uImage lzma
UBINIZE_OPTS := -E 5
- IMAGE/sysupgrade.bin := append-kernel | append-ubi | check-size $$$$(IMAGE_SIZE)
+ IMAGE/sysupgrade.bin := append-kernel | append-ubi | append-metadata | check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := NETIS WF-2881
DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport
endef
@@ -177,7 +177,7 @@ define Device/ubnt-erx
KERNEL := $(KERNEL_DTB) | uImage lzma
IMAGES := sysupgrade.tar
KERNEL_INITRAMFS := $$(KERNEL) | ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
- IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGE/sysupgrade.tar := sysupgrade-tar | append-metadata
DEVICE_TITLE := Ubiquiti EdgeRouter X
DEVICE_PACKAGES := -kmod-mt76 -kmod-rt2x00-lib -kmod-mac80211 -kmod-cfg80211 -wpad-mini -iwinfo
endef