aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-04-01 10:46:44 +0200
committerMathias Kresin <dev@kresin.me>2017-04-25 19:29:59 +0200
commit3cfc909c54c07d5a24d9a1a7496142b82d580878 (patch)
treecf174b5ef65ab1a8e2551b5a2038538b39b24f57 /target/linux/ramips/image/mt7621.mk
parent619d68bfc90e548e3398b26a2a0ca3fccd7d3f38 (diff)
downloadupstream-3cfc909c54c07d5a24d9a1a7496142b82d580878.tar.gz
upstream-3cfc909c54c07d5a24d9a1a7496142b82d580878.tar.bz2
upstream-3cfc909c54c07d5a24d9a1a7496142b82d580878.zip
ramips: rename Digineo AC1200 Pro to ZBT-WG3526 32MB
The Digineo AC1200 Pro is the 32MB flash variant of the ZBT-WG3526 with unpopulated/exposed sdhci slot. Rename to board to the OEM/ODM name and add the sdhci kernel module to use it for multiple clones. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk17
1 files changed, 9 insertions, 8 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ae5bf5e173..b57552a6f4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -34,14 +34,6 @@ define Device/11acnas
endef
TARGET_DEVICES += 11acnas
-define Device/ac1200pro
- DTS := AC1200pro
- IMAGE_SIZE := $(ralink_default_fw_size_32M)
- DEVICE_TITLE := Digineo AC1200 Pro
- DEVICE_PACKAGES := kmod-usb3 kmod-ata-core kmod-ata-ahci
-endef
-TARGET_DEVICES += ac1200pro
-
define Device/dir-860l-b1
DTS := DIR-860L-B1
BLOCKSIZE := 64k
@@ -270,6 +262,15 @@ define Device/zbt-wg3526-16M
endef
TARGET_DEVICES += zbt-wg3526-16M
+define Device/zbt-wg3526-32M
+ DTS := ZBT-WG3526-32M
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ SUPPORTED_DEVICES += ac1200pro
+ DEVICE_TITLE := ZBT WG3526 (32MB flash)
+ DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620
+endef
+TARGET_DEVICES += zbt-wg3526-32M
+
# FIXME: is this still needed?
define Image/Prepare
#define Build/Compile