aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2019-08-29 20:12:30 +0200
committerDavid Bauer <mail@david-bauer.net>2019-08-31 10:31:00 +0200
commit3c8df280a96bbd81357d6eb52845e6b5fa7162fe (patch)
tree1532b3d03d66d3a0d48bc8c72364560ac6997d9c /target/linux/ramips/image/mt7621.mk
parent9861fa7abab97cb928aaa6cd5732a413d973ac95 (diff)
downloadupstream-3c8df280a96bbd81357d6eb52845e6b5fa7162fe.tar.gz
upstream-3c8df280a96bbd81357d6eb52845e6b5fa7162fe.tar.bz2
upstream-3c8df280a96bbd81357d6eb52845e6b5fa7162fe.zip
ramips: add factory image for Netgear R6350
This adds factory image generation for all three devices. These images can be flashed via WebUI for easy installation. Thanks to David Bauer for the inspiration. Signed-off-by: Christoph Krapp <achterin@googlemail.com> [altered commit to only include the R6350] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 3b79c509f3..96dd74afcf 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -421,7 +421,12 @@ define Device/netgear_r6350
KERNEL_SIZE := 4096k
IMAGE_SIZE := 40960k
UBINIZE_OPTS := -E 5
- IMAGES += kernel.bin rootfs.bin
+ SERCOMM_HWID := CHJ
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x0052
+ IMAGES += factory.img kernel.bin rootfs.bin
+ IMAGE/factory.img := pad-extra 2048k | append-kernel | pad-to 6144k | append-ubi | \
+ pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | zip $$$$(DEVICE_MODEL).bin | sercom-seal
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)