aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-29 18:21:53 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-01 19:35:35 +0100
commit3227afbbabf06ac68a27bb5ad68c1928a06c4203 (patch)
tree7ea68d1ef941db82d3b85248349e99399e0a576c /target/linux/ramips/image/mt7621.mk
parentffbb8ed5a265930f9c20af826040f9d41e145c15 (diff)
downloadupstream-3227afbbabf06ac68a27bb5ad68c1928a06c4203.tar.gz
upstream-3227afbbabf06ac68a27bb5ad68c1928a06c4203.tar.bz2
upstream-3227afbbabf06ac68a27bb5ad68c1928a06c4203.zip
ramips: collect and harmonize TP-Link image variants in common file
This moves the various variants of common device definitions for TP-Link devices to a common Makefile common-tp-link.mk. This provides the opportunity to reorganize and move parameters between individual device definitions and the common ones. While at it, also use the common definitions for previously independent definitions where appropriate. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk16
1 files changed, 2 insertions, 14 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index be2a329524..6d0af9d994 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2,10 +2,11 @@
# MT7621 Profiles
#
+include ./common-tp-link.mk
+
DEFAULT_SOC := mt7621
KERNEL_DTB += -d21
-DEVICE_VARS += TPLINK_BOARD_ID TPLINK_HEADER_VERSION TPLINK_HWID TPLINK_HWREV
define Build/elecom-gst-factory
$(eval product=$(word 1,$(1)))
@@ -662,19 +663,6 @@ define Device/adslr_g7
endef
TARGET_DEVICES += adslr_g7
-define Device/tplink-safeloader
- DEVICE_VENDOR := TP-Link
- TPLINK_BOARD_ID :=
- TPLINK_HWID := 0x0
- TPLINK_HWREV := 0
- TPLINK_HEADER_VERSION := 1
- KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
- IMAGES += factory.bin
- IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
-endef
-
define Device/tplink_re350-v1
$(Device/tplink-safeloader)
DEVICE_MODEL := RE350