aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorValentín Kivachuk <vk18496@gmail.com>2018-11-30 00:13:53 +0100
committerMathias Kresin <dev@kresin.me>2018-11-30 00:20:28 +0100
commit30a7ab8f61c8a5f1a4428f8c7cf9a1d6a12b096b (patch)
treeff4467e70ae014c1257c8b737ef0df6c1d8ec090 /target/linux/ramips/image/mt7621.mk
parent493c1d17663dbfdaf23304994e71280400493fc2 (diff)
downloadupstream-30a7ab8f61c8a5f1a4428f8c7cf9a1d6a12b096b.tar.gz
upstream-30a7ab8f61c8a5f1a4428f8c7cf9a1d6a12b096b.tar.bz2
upstream-30a7ab8f61c8a5f1a4428f8c7cf9a1d6a12b096b.zip
ramips: add support for MTC Wireless Router WR1201
MTC Wireless Router WR1201 is the OEM name of the board. It is also sold rebranded as STRONG Dual Band Gigabit Router 1200. Specification: - SoC: MediaTek MT7621A (880 MHz) - Flash: 16 MiB - RAM: 128 MiB - Wireless: 2.4Ghz(MT7602EN) and 5Ghz (MT7612EN) - Ethernet speed: 10/100/1000 - Ethernet ports: 4+1 - 1x USB 3.0 - 1x microSD reader - Serial baud rate of Bootloader and factory firmware: 57600 The OEM webinterface writes only as much bytes as listed in the uImage header field to the flash. Also, the OEM webinterface evaluates the name field of uImage header before flashing (the string "WR1201_8_128") To flash via webinterface, is mandatory to use first initramfs.bin and after (from the OpenWrt) the sysupgrade.bin Some notes: - Some microSD will not work: mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising SDIO card mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising MMC card mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising SDIO card mtk-sd 1e130000.sdhci: card claims to support voltages below defined range mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising MMC card mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising SDIO card mtk-sd 1e130000.sdhci: no support for card's volts mmc0: error -22 whilst initialising MMC card Signed-off-by: Valentín Kivachuk <vk18496@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d0cf51f7e9..6a04cd0e38 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -47,6 +47,19 @@ define Build/iodata-factory
fi
endef
+# The OEM webinterface expects an kernel with initramfs which has the uImage
+# header field ih_name.
+# We don't wan't to set the header name field for the kernel include in the
+# sysupgrade image as well, as this image shouldn't be accepted by the OEM
+# webinterface. It will soft-brick the board.
+define Build/wr1201-factory-header
+ mkimage -A $(LINUX_KARCH) \
+ -O linux -T kernel \
+ -C lzma -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
+ -n 'WR1201_8_128' -d $@ $@.new
+ mv $@.new $@
+endef
+
define Build/ubnt-erx-factory-image
if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
echo '21001:6' > $(1).compat; \
@@ -317,6 +330,16 @@ define Device/mikrotik_rbm11g
endef
TARGET_DEVICES += mikrotik_rbm11g
+define Device/mtc_wr1201
+ DTS := WR1201
+ IMAGE_SIZE := 16000k
+ DEVICE_TITLE := MTC Wireless Router WR1201
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | wr1201-factory-header
+ DEVICE_PACKAGES := kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3 \
+ kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += mtc_wr1201
+
define Device/re350-v1
DTS := RE350
DEVICE_TITLE := TP-LINK RE350 v1