aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-07 21:33:51 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-17 14:01:31 +0100
commit19800ac095f6ddbba03ccab08e5197b1eec4a49e (patch)
tree96252e491e8528e222e5f1c902d357a54ead246c /target/linux/ramips/image/mt7621.mk
parenta9d3084b83bb2d0fa2c0b43bf2a0831b5ae1df13 (diff)
downloadupstream-19800ac095f6ddbba03ccab08e5197b1eec4a49e.tar.gz
upstream-19800ac095f6ddbba03ccab08e5197b1eec4a49e.tar.bz2
upstream-19800ac095f6ddbba03ccab08e5197b1eec4a49e.zip
ramips: set uImage name of WeVO 11AC NAS and W2914NS v2
The stock firmware and bootloader only accept uImage with names that match certain patterns. This patch enables OpenWrt installation from stock firmware without having to reflash the bootloader or access the UART console. Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 66afe29620..d663aa29da 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -738,6 +738,7 @@ TARGET_DEVICES += unielec_u7621-06-64m
define Device/wevo_11acnas
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
+ UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
DEVICE_VENDOR := WeVO
DEVICE_MODEL := 11AC NAS Router
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
@@ -748,6 +749,7 @@ TARGET_DEVICES += wevo_11acnas
define Device/wevo_w2914ns-v2
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
+ UIMAGE_NAME := W2914NS-V2(0.0.0)
DEVICE_VENDOR := WeVO
DEVICE_MODEL := W2914NS
DEVICE_VARIANT := v2