aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDaniel Danzberger <daniel@dd-wrt.com>2019-07-22 12:54:06 +0200
committerPetr Štetiar <ynezz@true.cz>2019-09-20 11:36:27 +0200
commit10c5d3dd5f52e15204b8446068d5fc55e02d2029 (patch)
treed42c2d6244ba01f57a8e3b54008b17e75e0cc9c4 /target/linux/ramips/image/mt7621.mk
parentfde8e2e035f74ed6e21b3aaf8f24a094b1dd9dc4 (diff)
downloadupstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.tar.gz
upstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.tar.bz2
upstream-10c5d3dd5f52e15204b8446068d5fc55e02d2029.zip
ramips: mt7621: Add new device AsiaRF AP7621-NV1
SoC: Mediatek MT7621A CPU: 4x 880Mhz Cache: 32 KB I-Cache and 32 KB D-Cach 256 KB L2 Cache (shared by Dual-Core) RAM: DDR3 512MB 16bits BUS FLASH: 16MB Switch: Mediatek Gigabit Switch (2 x LAN, 1 x WAN) POE: (1x PD, 2x PSE) USB: 1x 3.0 PCI: 3x Mini PCIe (3 USB2.0 + 2 x UIM interface) GPS: Quectel L70B SIM: 2 Slots BTN: Reset LED: - Power - Ethernet - Wifi - USB UART: UART is present as Pads with throughholes on the PCB. They are located on left side. 3.3V - RX - GND - TX / 57600-8N1 3.3V is the square pad Installation ------------ The stock image is a modified openwrt and can be overflashed via sysupgrade -F Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com> [merge conflict in mt7621.mk] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 1727f998c8..f098976dfc 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -125,6 +125,16 @@ define Device/asiarf_ap7621-001
endef
TARGET_DEVICES += asiarf_ap7621-001
+define Device/asiarf_ap7621-nv1
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16000k
+ DEVICE_VENDOR := AsiaRF
+ DEVICE_MODEL := AP7621-NV1
+ DEVICE_PACKAGES := \
+ kmod-sdhci-mt7620 kmod-mt76x2 kmod-usb3
+endef
+TARGET_DEVICES += asiarf_ap7621-nv1
+
define Device/asus_rt-ac57u
MTK_SOC := mt7621
DEVICE_VENDOR := ASUS