aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-11-12 01:26:44 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-12-13 15:37:37 +0100
commit0375c076b67cda9dc1b758b87ab1b79fd2403d94 (patch)
tree7ff5091a44f06edd3d398831c1718ec34e6edc38 /target/linux/ramips/image/mt7621.mk
parent69fff339e965d508b4fc12ffdc2a170efe9c98b1 (diff)
downloadupstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.tar.gz
upstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.tar.bz2
upstream-0375c076b67cda9dc1b758b87ab1b79fd2403d94.zip
ramips: add support for ZIO FREEZIO
ZIO FREEZIO is a 2.4/5GHz band AC1200 router, based on MediaTek MT7621A. Specifications: - SoC: MT7621AT - RAM: DDR3 128MB - Flash: SPI NOR 16MB - WiFi: - 2.4GHz: MT7603EN - 5GHz: MT7612EN - Ethernet: 5x 10/100/1000Mbps - Switch: SoC internal - USB: 1x 3.0 - UART: - J4: 3.3V, RX, TX, GND (3.3V is the square pad) / 57600 8N1 Notes: - FREEZIO has almost the same board as WeVO W2914NS v2. - Stock firmware is based on OpenWrt BB. MAC addresses in factory partition: 0x0004: WiFi 2.4GHz (label_mac-8) 0x002e: WAN (label_mac) 0x8004: WiFi 5GHz (label_mac-4) 0xe000: LAN (label_mac+1) Installation via web interface: 1. Access web admin page and turn on "OpenWrt UI mode". 2. Flash sysupgrade image through LuCI, with the "Keep settings" option OFF. Revert to stock firmware: 1. Perform sysupgrade with stock image. Make sure to NOT preserve settings. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [rebase, use mt7621_wevo_w2914ns-v2.dtsi] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d663aa29da..0b2b74800a 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -910,3 +910,12 @@ define Device/zbtlink_zbt-wg3526-32m
SUPPORTED_DEVICES += ac1200pro zbt-wg3526-32M
endef
TARGET_DEVICES += zbtlink_zbt-wg3526-32m
+
+define Device/zio_freezio
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ZIO
+ DEVICE_MODEL := FREEZIO
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += zio_freezio