aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorJackson Ming Hu <huming2207@gmail.com>2017-12-15 11:51:33 +0800
committerMathias Kresin <dev@kresin.me>2017-12-21 01:05:16 +0100
commitc0e131b4363dde16a1071131b7e762e36099f780 (patch)
tree180ee78c232b121b8d461ed6f131f71d6d83b19e /target/linux/ramips/image/mt7621.mk
parentfe6f298b07941758a759354c6751188c825c5ffb (diff)
downloadupstream-c0e131b4363dde16a1071131b7e762e36099f780.tar.gz
upstream-c0e131b4363dde16a1071131b7e762e36099f780.tar.bz2
upstream-c0e131b4363dde16a1071131b7e762e36099f780.zip
ramips: add support for newifi d2
Previously Newifi D2 could only use PandoraBox M1's firmware. It works fine, but LED GPIO is different. As a result, a separated DTS file for this device should be implemented. Hardware spec: * CPU: MTK MT7621A * RAM: 512MB * ROM: 32MB SPI Flash * WiFi: MTK MT7603+MT7612 * Button: 2 buttons (reset, wps) * LED: 3 single-color LEDs (USB, WiFi 2.4GHz, WiFi 5GHz) & 2 dual-color LEDs (Power, Internet) * Ethernet: 5 ports, 4 LAN + 1 WAN Installation method: Same as Newifi D1, users may need to request unlock code from the device manufacturer. Otherwise, a SPI flash programmer may be necessary to get the firmware flashed. After the device is unlocked, press and hold reset button before power cable plugs in. Then go to http://192.168.1.1 to upload and flash the firmware package. Signed-off-by: Jackson Ming Hu <huming2207@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ca1e3661b1..8ba65a1af2 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -142,6 +142,15 @@ define Device/newifi-d1
endef
TARGET_DEVICES += newifi-d1
+define Device/d-team_newifi-d2
+ DTS := Newifi-D2
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
+ DEVICE_TITLE := Newifi D2
+ DEVICE_PACKAGES := \
+ kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += d-team_newifi-d2
+
define Device/pbr-m1
DTS := PBR-M1
IMAGE_SIZE := $(ralink_default_fw_size_16M)