aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorDavide Ammirata <list@davidea.it>2018-05-03 15:59:27 +0000
committerMathias Kresin <dev@kresin.me>2018-05-07 18:54:23 +0200
commit004cc22e4ef8187dd80d5d6be5a2575453ef3699 (patch)
treeb8e27c07ebd6ed63e68e100d3ec8ffca25b8108a /target/linux/ramips/image/mt7621.mk
parent5ef79af4f80f772772e44e38478f2b3b78d40732 (diff)
downloadupstream-004cc22e4ef8187dd80d5d6be5a2575453ef3699.tar.gz
upstream-004cc22e4ef8187dd80d5d6be5a2575453ef3699.tar.bz2
upstream-004cc22e4ef8187dd80d5d6be5a2575453ef3699.zip
ramips: add support for mqmaker witi 512mb version
Splitted out the dts file and create the new dts for the 256 MByte RAM and the 512 MB RAM version. Migrate both versions to the common board detection. The install the 512 MByte Version on a board running the 256 MByte image, a forceful sysupgrade with the -F flag is required. Signed-off-by: Davide Ammirata <list@davidea.it>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk19
1 files changed, 15 insertions, 4 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d78175cf74..b84b74a5b0 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -310,15 +310,26 @@ define Device/wf-2881
endef
TARGET_DEVICES += wf-2881
-define Device/witi
- DTS := WITI
+define Device/mqmaker_witi-256m
+ DTS := WITI-256M
IMAGE_SIZE := $(ralink_default_fw_size_16M)
- DEVICE_TITLE := MQmaker WiTi
+ DEVICE_TITLE := MQmaker WiTi (256MB RAM)
DEVICE_PACKAGES := \
kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-sdhci-mt7620 kmod-usb3 \
kmod-usb-ledtrig-usbport wpad-mini
+ SUPPORTED_DEVICES += witi
endef
-TARGET_DEVICES += witi
+TARGET_DEVICES += mqmaker_witi-256m
+
+define Device/mqmaker_witi-512m
+ DTS := WITI-512M
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := MQmaker WiTi (512MB RAM)
+ DEVICE_PACKAGES := \
+ kmod-ata-core kmod-ata-ahci kmod-mt76x2 kmod-sdhci-mt7620 kmod-usb3 \
+ kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += mqmaker_witi-512m
define Device/wndr3700v5
DTS := WNDR3700V5