aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7621.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-08-16 14:05:53 +0200
committerJohn Crispin <john@phrozen.org>2019-10-21 14:27:30 +0200
commit4408723d42e0d717a0643422690686187cc7c2b1 (patch)
tree50a62d299ee3eafd114b093fe62ffe1b7d92c5a0 /target/linux/ramips/image/mt7621.mk
parentcc5256a8bfa0bd5fff5ff42e6b2febea011e1c59 (diff)
downloadupstream-4408723d42e0d717a0643422690686187cc7c2b1.tar.gz
upstream-4408723d42e0d717a0643422690686187cc7c2b1.tar.bz2
upstream-4408723d42e0d717a0643422690686187cc7c2b1.zip
ramips: remove RAM size from device name for UniElec devices
UniElec devices are the last ones in ramips target still having the RAM size in device name although RAM size is auto-detected. Remove this from device name, compatible, etc., as it's not required and might be misleading to users and developers adding device support copying those devices. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7621.mk')
-rw-r--r--target/linux/ramips/image/mt7621.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 95efcca202..afb0502174 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -682,24 +682,25 @@ define Device/ubiquiti_edgerouterx-sfp
endef
TARGET_DEVICES += ubiquiti_edgerouterx-sfp
-define Device/unielec_u7621-06-256m-16m
+define Device/unielec_u7621-06-16m
MTK_SOC := mt7621
IMAGE_SIZE := 16064k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
- DEVICE_VARIANT := 256M RAM/16M flash
+ DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
- SUPPORTED_DEVICES += u7621-06-256M-16M
+ SUPPORTED_DEVICES += u7621-06-256M-16M unielec,u7621-06-256m-16m
endef
TARGET_DEVICES += unielec_u7621-06-256m-16m
-define Device/unielec_u7621-06-512m-64m
+define Device/unielec_u7621-06-64m
MTK_SOC := mt7621
IMAGE_SIZE := 65216k
DEVICE_VENDOR := UniElec
DEVICE_MODEL := U7621-06
- DEVICE_VARIANT := 512M RAM/64M flash
+ DEVICE_VARIANT := 64M
DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+ SUPPORTED_DEVICES += unielec,u7621-06-512m-64m
endef
TARGET_DEVICES += unielec_u7621-06-512m-64m