aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-04-19 09:20:58 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-04-08 14:05:51 +0100
commitc948a4782ba9e99f690a75ddf95ad76add95b5fa (patch)
tree2821d94a508dce5b2145b493da7ae97eae051286 /target/linux/ramips/image/mt7620.mk
parent5a5a9b7a7500379e79410a8a955381ec0fa486ae (diff)
downloadupstream-c948a4782ba9e99f690a75ddf95ad76add95b5fa.tar.gz
upstream-c948a4782ba9e99f690a75ddf95ad76add95b5fa.tar.bz2
upstream-c948a4782ba9e99f690a75ddf95ad76add95b5fa.zip
ramips: add support for D-Link DWR-960
The DWR-960 Wireless Router is based on the MT7620A SoC. Specification: - MediaTek MT7620A (580 Mhz) - 128 MB of RAM - 16 MB of FLASH - 1x 802.11bgn radio - 1x 802.11ac radio (MT7610 mpcie card) - 4x 10/100 Mbps Ethernet (1 WAN and 3 LAN) - 1x 10/100/1000 Mbps Ethernet (1 LAN) (AR8035) - 2x internal, non-detachable antennas (Wifi 2.4G) - 3x external, detachable antennas (2x LTE, 1x Wifi 5G) - 1x LTE modem - UART (J4) header on PCB (57600 8n1) - 9x LED, 2x button - JBOOT bootloader Known issues: - Flash is extremely slow. Installation: Apply factory image via http web-gui or JBOOT recovery page How to revert to OEM firmware: - push the reset button and turn on the power. Wait until LED start blinking (~10sec.) - upload original factory image via JBOOT http (IP: 192.168.123.254) Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 552879e02f..d5365ac70e 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -279,6 +279,20 @@ define Device/dlink_dwr-922-e2
endef
TARGET_DEVICES += dlink_dwr-922-e2
+define Device/dlink_dwr-960
+ $(Device/amit_jboot)
+ SOC := mt7620a
+ IMAGE_SIZE := 16256k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DWR-960
+ DLINK_ROM_ID := DLK6E2429001
+ DLINK_FAMILY_MEMBER := 0x6E24
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ DEVICE_PACKAGES += kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi \
+ kmod-mt76x0e
+endef
+TARGET_DEVICES += dlink_dwr-960
+
define Device/dovado_tiny-ac
SOC := mt7620a
IMAGE_SIZE := 7872k