aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorLeonardo Mörlein <me@irrelefant.net>2021-05-09 22:28:15 +0200
committerPetr Štetiar <ynezz@true.cz>2021-05-13 15:13:15 +0200
commitb993b68b6ca8444b5227a0c18df4600b37ac565c (patch)
treea55300e2e43a57fa46a534d1135eee006a4b6d71 /target/linux/ramips/image/mt7620.mk
parentce8af0ace04bb43e8156940c771b4058fa83d27a (diff)
downloadupstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.gz
upstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.tar.bz2
upstream-b993b68b6ca8444b5227a0c18df4600b37ac565c.zip
build: introduce $(MKHASH)
Before this commit, it was assumed that mkhash is in the PATH. While this was fine for the normal build workflow, this led to some issues if make TOPDIR="$(pwd)" -C "$pkgdir" compile was called manually. In most of the cases, I just saw warnings like this: make: Entering directory '/home/.../package/gluon-status-page' bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found bash: line 1: mkhash: command not found [...] While these were only warnings and the package still compiled sucessfully, I also observed that some package even fail to build because of this. After applying this commit, the variable $(MKHASH) is introduced. This variable points to $(STAGING_DIR_HOST)/bin/mkhash, which is always the correct path. Signed-off-by: Leonardo Mörlein <me@irrelefant.net>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 64dc0715ed..3caeecebee 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -9,9 +9,9 @@ DEVICE_VARS += DLINK_ROM_ID DLINK_FAMILY_MEMBER DLINK_FIRMWARE_SIZE DLINK_IMAGE_
define Build/elecom-header
cp $@ $(KDIR)/v_0.0.0.bin
( \
- mkhash md5 $(KDIR)/v_0.0.0.bin && \
+ $(MKHASH) md5 $(KDIR)/v_0.0.0.bin && \
echo 458 \
- ) | mkhash md5 > $(KDIR)/v_0.0.0.md5
+ ) | $(MKHASH) md5 > $(KDIR)/v_0.0.0.md5
$(STAGING_DIR_HOST)/bin/tar -c \
$(if $(SOURCE_DATE_EPOCH),--mtime=@$(SOURCE_DATE_EPOCH)) \
--owner=0 --group=0 -f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5