aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-12-29 19:25:00 +0100
committerMathias Kresin <dev@kresin.me>2018-12-30 20:08:12 +0100
commit7c1332d95fbaea2e0a5029947a2b8d3d43c171b4 (patch)
treee8c69566ba38214068e6906ceec07c33c7657298 /target/linux/ramips/image/mt7620.mk
parentd3bf5ff9bc7b55b2a3dab93853b33a0cd2c4ca47 (diff)
downloadupstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.gz
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.tar.bz2
upstream-7c1332d95fbaea2e0a5029947a2b8d3d43c171b4.zip
ramips: consolidate seama image build code
Create a common template which has the required image build code defined. Add some new variables to pass individual parts to the seama recipes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk13
1 files changed, 2 insertions, 11 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 6b65856281..e487f529d6 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -135,20 +135,11 @@ endef
TARGET_DEVICES += db-wrt01
define Device/dch-m225
+ $(Device/seama)
DTS := DCH-M225
BLOCKSIZE := 4k
- IMAGES += factory.bin
+ SEAMA_SIGNATURE := wapn22_dlink.2013gui_dap1320b
IMAGE_SIZE := 6848k
- IMAGE/sysupgrade.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | append-rootfs | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
- IMAGE/factory.bin := \
- append-kernel | pad-offset $$$$(BLOCKSIZE) 64 | \
- append-rootfs | pad-rootfs -x 64 | \
- seama -m "dev=/dev/mtdblock/2" -m "type=firmware" | \
- seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
- check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := D-Link DCH-M225
DEVICE_PACKAGES := kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
endef