aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorNuno Goncalves <nunojpg@gmail.com>2020-08-13 23:26:13 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-27 21:20:16 +0100
commit2a860bf4f4d5e76bd61235eeade834b6f8e2c9fa (patch)
tree01428f5852c97ba7fa511e877018ca834619c98d /target/linux/ramips/image/mt7620.mk
parent29804086ee7b740224d01012656162a9518deb97 (diff)
downloadupstream-2a860bf4f4d5e76bd61235eeade834b6f8e2c9fa.tar.gz
upstream-2a860bf4f4d5e76bd61235eeade834b6f8e2c9fa.tar.bz2
upstream-2a860bf4f4d5e76bd61235eeade834b6f8e2c9fa.zip
ramips: add support for Wavlink WL-WN530HG4
Same hardware as Phicomm K2G but different flash layout. Specification: - SoC: MediaTek MT7620A - Flash: 8 MB - RAM: 64 MB - Ethernet: 4 FE ports and 1 GE port (RTL8211F on port 5) - Wireless radio: MT7620 for 2.4G and MT7612E for 5G, both equipped with external PA. - UART: 1 x UART on PCB - 57600 8N1 Flash instruction: To avoid requiring UART for TFTP a dual flash procedure is suggested to install the squashfs image: 1. Rename openwrt-ramips-mt7620-wavlink_wl-wn530hg4-initramfs-kernel.bin to WN530HG4-WAVLINK. 2. Flash this file with the factory web interface. 3. With OpenWRT now running use standard sysupgrade to install the squashfs image. Signed-off-by: Nuno Goncalves <nunojpg@gmail.com> [remove dts-v1, remove model from LED labels, wrap commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index d9725c9e69..dfdb5f28d3 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -1078,6 +1078,15 @@ define Device/vonets_var11n-300
endef
TARGET_DEVICES += vonets_var11n-300
+define Device/wavlink_wl-wn530hg4
+ SOC := mt7620a
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WL-WN530HG4
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += wavlink_wl-wn530hg4
+
define Device/wrtnode_wrtnode
SOC := mt7620n
IMAGE_SIZE := 16064k