aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorFrederik Noe-Sdun <Frederik.Sdun@googlemail.com>2019-07-29 20:23:28 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-08 18:16:14 +0100
commit0cbd2c74d0c9f41d07757907226e5cfeaf16e06a (patch)
tree3368f58bd39707eef689c97559e97a4a5706252e /target/linux/ramips/image/mt7620.mk
parent0ff2385a92c0a31769fce954b7bd571d6114dbc8 (diff)
downloadupstream-0cbd2c74d0c9f41d07757907226e5cfeaf16e06a.tar.gz
upstream-0cbd2c74d0c9f41d07757907226e5cfeaf16e06a.tar.bz2
upstream-0cbd2c74d0c9f41d07757907226e5cfeaf16e06a.zip
ramips: add support for Netgear EX6130
Specifications: * SoC: MT7620A * RAM: 64 MB DDR * Flash: 8MB NOR SPI flash * WiFi: MT7612E (5Ghz) and builtin MT7620A (2.4GHz) * LAN: 1x100M The -factory images can be flashed from the device's web interface or via nmrpflash. The device seems to use base PCB as EX3700/EX3800, but supporting AC1200 using MT7612E. MAC adresses: 5.0 GHz 0x8004 *:9a 2.4 GHz 0x4 *:9b lan 0x28 *:9b wan 0x2e *:9c Since this is a one-port device, although wan MAC address is set in flash, it is not used in OpenWrt setup. Signed-off-by: Frederik Noe-Sdun <Frederik.Sdun@googlemail.com> [rebased, extended commit message, tiny DTS style fixes] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 88437a6904..d3de3074b2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -612,6 +612,19 @@ define Device/netgear_ex3700
endef
TARGET_DEVICES += netgear_ex3700
+define Device/netgear_ex6130
+ MTK_SOC := mt7620a
+ NETGEAR_BOARD_ID := U12H319T50_NETGEAR
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGES += factory.chk
+ IMAGE/factory.chk := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
+ DEVICE_PACKAGES := kmod-mt76x2
+ DEVICE_VENDOR := NETGEAR
+ DEVICE_MODEL := EX6130
+endef
+TARGET_DEVICES += netgear_ex6130
+
define Device/netgear_wn3000rp-v3
MTK_SOC := mt7620a
IMAGE_SIZE := 7872k