aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorThibaut VARENE <hacks@slashdirt.org>2017-01-18 11:34:56 +0100
committerJo-Philipp Wich <jo@mein.io>2017-04-28 17:07:24 +0200
commit1aee42c6a9d297e5a8bd241318338217b86c3070 (patch)
tree209cf486541bfc4edeaa6fb61daa382a93dcbe1e /target/linux/ramips/image/mt7620.mk
parent846457fdbffaffdf44d668715e88cb21765ec6c9 (diff)
downloadupstream-1aee42c6a9d297e5a8bd241318338217b86c3070.tar.gz
upstream-1aee42c6a9d297e5a8bd241318338217b86c3070.tar.bz2
upstream-1aee42c6a9d297e5a8bd241318338217b86c3070.zip
ramips: add support for Netgear WN3000RPv3
This patch adds support for the Netgear WN3000RPv3 http://www.netgear.com/support/product/wn3000rpv3.aspx Specifications: - SoC: MediaTek MT7620A (580MHz, ramips) - RAM: 32MB DDR - Storage: 8MB NOR SPI flash - Wireless: builtin MT7620A, 2x2:2 with u.FL connectors - Ethernet: 1x100M - Serial: JP1 header, 57600-8N1 - Stock firmware based on OpenWRT Kamikaze Like the EX2700, the bootloader expects a secondary image signature, see https://forum.openwrt.org/viewtopic.php?pid=312577#p312577 This is why the same fakeroot image is used for the WN3000 Signed-off-by: Thibaut VARENE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 1889bcf708..42e0ab63c2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -75,6 +75,17 @@ define Device/ex2700
endef
TARGET_DEVICES += ex2700
+define Device/wn3000rpv3
+ DTS := WN3000RPV3
+ BLOCKSIZE := 4k
+ IMAGES += factory.bin
+ KERNEL := $(KERNEL_DTB) | uImage lzma | pad-kernel-ex2700
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ netgear-header -B WN3000RPv3 -H 29764836+8+0+32+2x2+0
+ DEVICE_TITLE := Netgear WN3000RPv3
+endef
+TARGET_DEVICES += wn3000rpv3
+
define Device/wt3020-4M
DTS := WT3020-4M
BLOCKSIZE := 4k