aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorDaniel Kucera <daniel.kucera@gmail.com>2017-02-19 09:46:44 +0100
committerMathias Kresin <dev@kresin.me>2017-10-14 10:48:29 +0200
commit6f008af3f0b30d2af21ad6934c17b0ae69103ecd (patch)
tree38a4acdc3512354fa9befec44f591bcc831d0913 /target/linux/ramips/image/mt7620.mk
parentf2b7d9dc1ca3d33f14961cf2885639f4f9e8965e (diff)
downloadupstream-6f008af3f0b30d2af21ad6934c17b0ae69103ecd.tar.gz
upstream-6f008af3f0b30d2af21ad6934c17b0ae69103ecd.tar.bz2
upstream-6f008af3f0b30d2af21ad6934c17b0ae69103ecd.zip
ramips: add support for Kimax U25AWF-H1
Kimax U-25AWF-H1 is is a 2,5" HDD Enclosure with Wi-Fi/Eth conection and battery, based on MediaTek MT7620A. Patch rewritten from: https://forum.openwrt.org/viewtopic.php?pid=305643 Specification: - MT7620A CPU - 64 MB of RAM - 16 MB of FLASH - 802.11bgn WiFi - 1x 10/100 Mbps Ethernet - USB 2.0 Host - UART for serial console Flash instruction: 1. Download lede-ramips-mt7620-u25awf-h1-squashfs-sysupgrade.bin 2. Open webinterface a upgrade 3. After boot connect via ethernet to ip 192.168.1.1 Signed-off-by: Daniel Kucera <daniel.kucera@gmail.com> [fix reset button gpio, don't add a lan/wan vlan config for single port board, add -H1 suffix do make sure that this revision of the board is supported/tested] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 8a7eaf4ae6..f45a7189b3 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -193,6 +193,13 @@ define Device/gl-mt300a
endef
TARGET_DEVICES += gl-mt300a
+define Device/u25awf-h1
+ DTS := U25AWF-H1
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := Kimax U25AWF-H1
+endef
+TARGET_DEVICES += u25awf-h1
+
define Device/gl-mt300n
DTS := GL-MT300N
IMAGE_SIZE := $(ralink_default_fw_size_16M)