aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-03-19 19:15:29 +0100
committerPetr Štetiar <ynezz@true.cz>2019-03-24 01:44:24 +0100
commit67fced9ba336dd69c5a35aec3157db4b158a9e2d (patch)
tree1203504bb73e691a34c91a686dc051d88f17f913 /target/linux/ramips/image/mt7620.mk
parent1f149fcad38677cc917d249e32b4b791cde95702 (diff)
downloadupstream-67fced9ba336dd69c5a35aec3157db4b158a9e2d.tar.gz
upstream-67fced9ba336dd69c5a35aec3157db4b158a9e2d.tar.bz2
upstream-67fced9ba336dd69c5a35aec3157db4b158a9e2d.zip
ramips: add support for DLINK DIR-510L
The DIR-510L Wireless Router are based on the MT7620A SoC. Specification: -MediaTek MT7620A (580 Mhz) -128 MB of RAM -16 MB of FLASH -802.11bgn radio -1x 10/100 Mbps Ethernet -2x internal, non-detachable antennas -UART (J3) header on PCB (57600 8n1) -1x bi-color LED (GPIO-controlled), 2x button -JBOOT bootloader Known issues: -Ethernet port is used as LAN -No communication with charger IC. (uart bitbang needed) Installation: Apply factory image via d-link http web-gui. How to revert to OEM firmware: 1.) Push the reset button and turn on the power. Wait until LED start blinking (~10sec.) 2.) Upload original factory image via JBOOT http (IP: 192.168.123.254) 3.) If http doesn't work, it can be done with curl command: curl -F FN=@XXXXX.bin http://192.168.123.254/upg where XXXXX.bin is name of firmware file. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [fixed whitespace issue in 10-rt2x00-eeprom] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 234b6df098..da90568df0 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -190,6 +190,18 @@ define Device/dir-810l
endef
TARGET_DEVICES += dir-810l
+define Device/dlink_dir-510l
+ $(Device/amit_jboot)
+ DTS := DIR-510L
+ DEVICE_TITLE := D-Link DIR-510L
+ DEVICE_PACKAGES += kmod-mt76x0e
+ DLINK_ROM_ID := DLK6E3805001
+ DLINK_FAMILY_MEMBER := 0x6E38
+ DLINK_FIRMWARE_SIZE := 0xDE0000
+ DLINK_IMAGE_OFFSET := 0x210000
+endef
+TARGET_DEVICES += dlink_dir-510l
+
define Device/dlink_dwr-116-a1
$(Device/amit_jboot)
DTS := DWR-116-A1