aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorØrjan Malde <foxyred333@gmail.com>2017-05-05 17:54:26 +0200
committerMathias Kresin <dev@kresin.me>2017-05-10 08:45:12 +0200
commit5f932988c3b65af14bd6e48a05cc2204b7aeb419 (patch)
tree3f8f38ecb48af60c527363490c8ff3d1b8d1c7d9 /target/linux/ramips/image/mt7620.mk
parenta7cbf59e0e04a24b91a112e9b2e1a72ed5b4c1f6 (diff)
downloadupstream-5f932988c3b65af14bd6e48a05cc2204b7aeb419.tar.gz
upstream-5f932988c3b65af14bd6e48a05cc2204b7aeb419.tar.bz2
upstream-5f932988c3b65af14bd6e48a05cc2204b7aeb419.zip
ramips: add support for Asus RT-AC51U
Specification: - SoC: MediaTek MT7620A (580 MHz) - RAM: 64 MiB (Winbond W9751G6JB-25) - Flash: 16 MiB (Spansion S25FL128SAIF00) - LAN: x4 100M - WAN: x1 100M - Others: USB 2.0, reset button, wps button and 9 LEDs Issues: - 5 GHz band is not functional (missing driver support) Installation: Asus windows recovery tool: - install the Asus firmware restoration utility - unplug the router, hold the reset button while powering it on - release when the power LED flashes slowly - specify a static IP on your computer: IP address: 192.168.1.75; Subnet mask 255.255.255.0 - Start the Asus firmware restoration utility, specify the sysupgrade image, and press upload TFTP Recovery method: - set computer to a static ip, 192.168.1.75 - connect computer to the LAN 1 port of the router - hold the reset button while powering on the router for a few seconds - send firmware image using a tftp client; i.e from linux: $ tftp tftp> binary tftp> connect 192.168.1.1 tftp> put lede-ramips-mt7620-rt-ac51u-squashfs-sysupgrade.bin tftp> quit Signed-off-by: Ørjan Malde <foxyred333@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 5f7798f029..73f91cfedd 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -354,6 +354,14 @@ define Device/rt-n14u
endef
TARGET_DEVICES += rt-n14u
+define Device/rt-ac51u
+ DTS := RT-AC51U
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := Asus RT-AC51U
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += rt-ac51u
+
define Device/tiny-ac
DTS := TINY-AC
DEVICE_TITLE := Dovado Tiny AC