aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorNick Briggs <nicholas.h.briggs@gmail.com>2019-07-19 20:01:29 -0700
committerPetr Štetiar <ynezz@true.cz>2019-09-20 11:36:27 +0200
commit3df3bb0dae9e633d843223afb98bd787ad9d6022 (patch)
treef68b1893d884b2e6feab49ea055b074d413f15ad /target/linux/ramips/image/mt7620.mk
parent10c5d3dd5f52e15204b8446068d5fc55e02d2029 (diff)
downloadupstream-3df3bb0dae9e633d843223afb98bd787ad9d6022.tar.gz
upstream-3df3bb0dae9e633d843223afb98bd787ad9d6022.tar.bz2
upstream-3df3bb0dae9e633d843223afb98bd787ad9d6022.zip
ramips: add support for EnGenius ESR600
The EnGenius ESR600 is a dual band wireless router with a 4-port gigabit Ethernet switch, a gigabit Ethernet WAN port and a USB port. Specification: - Bootloader: U-Boot - SoC: MediaTek MT7620A (600 MHz) - Flash: 16MB, Macronix MX25L12845E - RAM: 64MB, Nanya NT5TU32M16DG-AC - Serial: 115200 baud, no header, 3.3V J2: Vcc (arrow), Gnd, Tx, Rx - USB: USB 2, 5V - Ethernet: 5 x 1 Gb/s 4 LAN 1 WAN, Atheros AR8327 - WiFi0: 5 GHz 802.11 b/g/n Ralink RT5592N 300 Mb/s, 2T2R - WiFi1: 2.4 GHz 802.11 b/g/n integrated 300 Mb/s, 2T2R - Antennas: 2 per radio, internal - LEDs: 1 programmable power (amber) 2 programable radio (blue) 1 programable WPS-5G (blue) 1 non-programable WAN activity (blue) 1 unconfigured WPS-2.4G (amber) - Buttons: GPIO: Reset, WPS Installation: Use the OEM web interface to install the ...-factory.dlf image. Use the OpenWRT ...-sysupgrade.bin image for future upgrades. The J2 serial port can be accessed either by soldering in a header, standard 0.1" spacing, or by using pogo-pins against the back side. As configured by the OEM, the U-Boot boot delay is short, however quickly typing "1" leads to the U-Boot "System load Linux to SDRAM via TFTP" prompt. The TFTP client is configured by default with client: 192.168.99.9 server: 192.168.99.8 filename: uImageESR600 It will load an OpenWRT initramfs kernel with this method. Known issues: 1) Only the ports externally labeled WAN, LAN3 and LAN4 are operational. LAN1 and LAN2 do not appear to power up. This issue is also present in the Lava LR25G001. 2) The amber WPS-2.4G LED, in the same lightguide as the blue WPS-5G LED, is not configured in the Device Tree specification. 3) The blue WAN activity LED is not configured in the Device Tree specification as this causes the AR8327 switch to fail to initialize. Signed-off-by: Nick Briggs <nicholas.h.briggs@gmail.com> [merge conflict in 02_network] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index e8f5db7d0a..320d4abd1f 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -372,6 +372,19 @@ define Device/elecom_wrh-300cr
endef
TARGET_DEVICES += elecom_wrh-300cr
+define Device/engenius_esr600
+ MTK_SOC := mt7620a
+ BLOCKSIZE := 64k
+ IMAGE_SIZE := 15616k
+ IMAGES += factory.dlf
+ IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ senao-header -r 0x101 -p 0x57 -t 2
+ DEVICE_VENDOR := EnGenius
+ DEVICE_MODEL := ESR600
+ DEVICE_PACKAGES += kmod-rt2800-pci kmod-usb-core kmod-usb-storage kmod-usb-ohci kmod-usb-ehci
+endef
+TARGET_DEVICES += engenius_esr600
+
define Device/fon_fon2601
MTK_SOC := mt7620a
IMAGE_SIZE := 15936k