aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2019-08-20 22:14:02 +0200
committerChristian Lamparter <chunkeey@gmail.com>2019-08-24 23:23:31 +0200
commit3dc5716b0782a5524cc0f2b41c9f02ba2aaf89bf (patch)
treeb68b04c08b0117242361db48278b924b845bdea6 /target/linux/ramips/image/mt7620.mk
parent8036345225ced243782dcea055889fd821897393 (diff)
downloadupstream-3dc5716b0782a5524cc0f2b41c9f02ba2aaf89bf.tar.gz
upstream-3dc5716b0782a5524cc0f2b41c9f02ba2aaf89bf.tar.bz2
upstream-3dc5716b0782a5524cc0f2b41c9f02ba2aaf89bf.zip
ramips: add NAS goodies on U25AWF-H1 + U35[N|W]F
These devices are sold as a "NAS HDD Enclousure" and have a "NAS Media Streaming & File Server & AP" on the box. That's why I think they should have some support for the HDD right out-of-the-box. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 455f836168..e8f5db7d0a 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -497,7 +497,8 @@ define Device/kimax_u25awf-h1
DEVICE_VENDOR := Kimax
DEVICE_MODEL := U25AWF
DEVICE_VARIANT := H1
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-storage kmod-scsi-core \
+ kmod-fs-ext4 kmod-fs-vfat block-mount
SUPPORTED_DEVICES += u25awf-h1
endef
TARGET_DEVICES += kimax_u25awf-h1
@@ -507,7 +508,8 @@ define Device/kimax_u35wf
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Kimax
DEVICE_MODEL := U35WF
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-storage kmod-scsi-core \
+ kmod-fs-ext4 kmod-fs-vfat block-mount
endef
TARGET_DEVICES += kimax_u35wf