aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2019-01-09 00:20:18 +0900
committerChristian Lamparter <chunkeey@gmail.com>2019-02-14 16:56:14 +0100
commitf305ce5c3577005aba5b870b373e65aaf9ede3ec (patch)
tree92801a53052461f74ca6e28bcf2d40c68fb1022a /target/linux/ramips/image/mt7620.mk
parentdee8db441e480e7d581447f43219596f6dd9542a (diff)
downloadupstream-f305ce5c3577005aba5b870b373e65aaf9ede3ec.tar.gz
upstream-f305ce5c3577005aba5b870b373e65aaf9ede3ec.tar.bz2
upstream-f305ce5c3577005aba5b870b373e65aaf9ede3ec.zip
ramips: add support for I-O DATA WN-AC1167GR
I-O DATA WN-AC1167GR is a 2.4/5 GHz band 11ac router, based on MediaTek MT7620A. Specification: - SoC : MediaTek MT7620A - RAM : DDR2 64 MB - Flash : SPI-NOR 8MB - WLAN : 2.4/5 GHz, 2T2R - 2.4 GHz: MT7620A (SoC) - 5 GHz : MT7612E - Ethernet: 10/100/1000 Mbps (ext. MT7530) - LED/key : 4x/3x (2x buttons, 1x slide-switch) - UART : through-hole on PCB - J2: TX, GND, RX, Vcc from SoC side - 115200n8 Flash instruction using factory image: 1. Boot WN-AC1167GR normaly 2. Access to "http://192.168.0.1/" and open firmware update page ("ファームウェア") 3. Select the OpenWrt factory image and click update ("更新") button to perform firmware update 4. Wait ~150 seconds to complete flashing Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 57903232ed..7ac228db16 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -16,6 +16,25 @@ define Build/elecom-header
-f $@ -C $(KDIR) v_0.0.0.bin v_0.0.0.md5
endef
+define Build/elx-header
+ $(eval hw_id=$(word 1,$(1)))
+ $(eval xor_pattern=$(word 2,$(1)))
+ ( \
+ echo -ne "\x00\x00\x00\x00\x00\x00\x00\x03" | \
+ dd bs=42 count=1 conv=sync; \
+ hw_id="$(hw_id)"; \
+ echo -ne "\x$${hw_id:0:2}\x$${hw_id:2:2}\x$${hw_id:4:2}\x$${hw_id:6:2}" | \
+ dd bs=20 count=1 conv=sync; \
+ echo -ne "$$(printf '%08x' $$(stat -c%s $@) | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+ dd bs=8 count=1 conv=sync; \
+ echo -ne "$$($(STAGING_DIR_HOST)/bin/mkhash md5 $@ | fold -s2 | xargs -I {} echo \\x{} | tr -d '\n')" | \
+ dd bs=58 count=1 conv=sync; \
+ ) > $(KDIR)/tmp/$(DEVICE_NAME).header
+ $(call Build/xor-image,-p $(xor_pattern) -x)
+ cat $(KDIR)/tmp/$(DEVICE_NAME).header $@ > $@.new
+ mv $@.new $@
+endef
+
define Device/ai-br100
DTS := AI-BR100
IMAGE_SIZE := 7936k
@@ -327,6 +346,18 @@ define Device/hc5861
endef
TARGET_DEVICES += hc5861
+define Device/iodata_wn-ac1167gr
+ DTS := WN-AC1167GR
+ DEVICE_TITLE := I-O DATA WN-AC1167GR
+ IMAGE_SIZE := 6864k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := \
+ $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+ elx-header 01040016 8844A2D168B45A2D
+ DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += iodata_wn-ac1167gr
+
define Device/kimax_u35wf
DTS := U35WF
IMAGE_SIZE := 16064k