aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>2017-03-03 15:36:51 +0100
committerMathias Kresin <dev@kresin.me>2017-03-12 09:28:19 +0100
commitde33a4cef0411f13df397ada2dc3634c5748a457 (patch)
treeda194a36f37938c6d0be065c0b9c9b7169fb371f /target/linux/ramips/image/mt7620.mk
parent2c2fc50d06cf18f7f5120a201e101aaa42f070c1 (diff)
downloadupstream-de33a4cef0411f13df397ada2dc3634c5748a457.tar.gz
upstream-de33a4cef0411f13df397ada2dc3634c5748a457.tar.bz2
upstream-de33a4cef0411f13df397ada2dc3634c5748a457.zip
ramips: add support for Netgear EX3700
Specifications: * SoC: MT7620A * RAM: 64 MB DDR * Flash: 8MB NOR SPI flash * WiFi: MT7612E (5Ghz) and builtin MT7620A (2.4GHz) * LAN: 1x100M The -factory images can be flashed from the device's web interface or via nmrpflash. Co-authored-by: Paul Oranje <por@xs4all.nl> Signed-off-by: Paul Oranje <por@xs4all.nl> Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 3ecd4ba3a1..bbf3f65830 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -79,6 +79,18 @@ define Device/wn3000rpv3
endef
TARGET_DEVICES += wn3000rpv3
+define Device/ex3700
+ NETGEAR_BOARD_ID := U12H319T00_NETGEAR
+ DTS := EX3700
+ BLOCKSIZE := 4k
+ IMAGE_SIZE := 7744k
+ IMAGES += factory.bin
+ IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | netgear-chk
+ DEVICE_PACKAGES := -kmod-mt76 kmod-mt76x2
+ DEVICE_TITLE := Netgear EX3700
+endef
+TARGET_DEVICES += ex3700
+
define Device/wt3020-4M
DTS := WT3020-4M
BLOCKSIZE := 4k