aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorHenryk Heisig <hyniu@o2.pl>2016-09-24 21:41:43 +0200
committerJohn Crispin <john@phrozen.org>2016-12-22 15:03:30 +0100
commitc8043137bbd323b1490ae8613eab915ba9c138ee (patch)
tree6ebd7b34943ad84fe7df3a008a03a319ccdf197c /target/linux/ramips/image/mt7620.mk
parent190ee7d86b450083fea4236d588d0d88a50e1311 (diff)
downloadupstream-c8043137bbd323b1490ae8613eab915ba9c138ee.tar.gz
upstream-c8043137bbd323b1490ae8613eab915ba9c138ee.tar.bz2
upstream-c8043137bbd323b1490ae8613eab915ba9c138ee.zip
ramips: Add support to TP-Link Archer MR200
CPU: MT7620N 580MHz Flash: 8MB RAM: 64MB build-in modem 3G/4G four ethernet port 10/100Mbps Signed-off-by: Henryk Heisig <hyniu@o2.pl>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 0bd6c9dcd8..d0e89b68a2 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -59,6 +59,16 @@ define Device/ArcherC50
endef
TARGET_DEVICES += ArcherC50
+define Device/ArcherMR200
+ DTS := ArcherMR200
+ KERNEL := $(KERNEL_DTB)
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-header ArcherMR200 -c
+ IMAGE/sysupgrade.bin := append-kernel | tplink-header ArcherMR200 -j -r $(KDIR)/root.squashfs
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-net kmod-usb-net-rndis kmod-usb-serial kmod-usb-serial-option adb
+ DEVICE_TITLE := TP-Link ArcherMR200
+endef
+TARGET_DEVICES += ArcherMR200
+
define Device/ex2700
DTS := EX2700
BLOCKSIZE := 4k