aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorGiuseppe Lippolis <giu.lippolis@gmail.com>2018-03-10 10:34:38 +0100
committerMathias Kresin <dev@kresin.me>2018-04-04 08:42:35 +0200
commit6525bffc0a7ee6fabfe331a4d9e3eeabdd3516ae (patch)
tree4d91984eefef92212b58ba195df91970e24f86bc /target/linux/ramips/image/mt7620.mk
parente9d5f8ebb25721c28a37390081fd4a08c3d0f8d4 (diff)
downloadupstream-6525bffc0a7ee6fabfe331a4d9e3eeabdd3516ae.tar.gz
upstream-6525bffc0a7ee6fabfe331a4d9e3eeabdd3516ae.tar.bz2
upstream-6525bffc0a7ee6fabfe331a4d9e3eeabdd3516ae.zip
ramips: add support for DLINK DWR-921-C1
The DWR-921-C1 Wireless Routers with LTE embedded modem is based on the MT7620N SoC. Specification: * MediaTek MT7620N (580 Mhz) * 64 MB of RAM * 16 MB of FLASH * 802.11bgn radio * 5x 10/100 Mbps Ethernet (1 WAN and 4 LAN) * 2x external, detachable (LTE) antennas * UART header on PCB (57600 8n1) * 6x LED (GPIO-controlled) * 1x bi-color Signal Strength LED (GPIO-controlled) * 2x button * JBOOT bootloader The status led has been assigned to the dwr-921-c1:green:sigstrength (lte signal strength) led. At the end of the boot it is switched off and is available for lte operation. Work correctly also during sysupgrade operation. Installation: Apply factory image via d-link http web-gui. How to revert to OEM firmware: 1.) Push the reset button and turn on the power. Wait until LED start blinking (~10sec.) 2.) Upload original factory image via JBOOT http (IP: 192.168.123.254) 3.) If http doesn't work, it can be done with curl command: curl -F FN=@XXXXX.bin http://192.168.123.254/upg where XXXXX.bin is name of firmware file. Signed-off-by: Giuseppe Lippolis <giu.lippolis@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index b352c5408d..185a081c90 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -162,6 +162,22 @@ define Device/dlink_dwr-116-a1
endef
TARGET_DEVICES += dlink_dwr-116-a1
+define Device/dlink_dwr-921-c1
+ DTS := DWR-921-C1
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := D-Link DWR-921 C1
+ DLINK_ROM_ID := DLK6E2414001
+ DLINK_FAMILY_MEMBER := 0x6E24
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+ IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
+ DEVICE_PACKAGES := jboot-tools \
+ kmod-usb2 kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
+endef
+TARGET_DEVICES += dlink_dwr-921-c1
+
define Device/e1700
DTS := E1700
IMAGES += factory.bin