aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2018-10-24 14:06:35 +0200
committerMathias Kresin <dev@kresin.me>2018-12-03 15:34:56 +0100
commite9a9b7d1ed76c88e097d5bc4dabf38735312558b (patch)
tree844dec550a138ed326345a8b3f1fdb8ade2ef6a6 /target/linux/ramips/image/mt7620.mk
parent40692f0fb55ca5bd2426701b3a9e64e3b7487a7d (diff)
downloadupstream-e9a9b7d1ed76c88e097d5bc4dabf38735312558b.tar.gz
upstream-e9a9b7d1ed76c88e097d5bc4dabf38735312558b.tar.bz2
upstream-e9a9b7d1ed76c88e097d5bc4dabf38735312558b.zip
ramips: add support for D-Link DWR-118-A1
The DWR-118-A1 Wireless Router is based on the MT7620A SoC. Specification: - MediaTek MT7620A (580 Mhz) - 64 MB of RAM - 16 MB of FLASH - 1x 802.11bgn radio - 1x 802.11ac radio (MT7610EN) - 3x 10/100 Mbps Ethernet (3 LAN) - 2x 10/100/1000 Mbps ICPlus IP1001 Ethernet PHY (1 WAN AND 1 LAN) - 1x internal, non-detachable antenna - 2x external, non-detachable antennas - 1x USB 2.0 - UART (J1) header on PCB (57600 8n1) - 7x LED (5x GPIO-controlled), 2x button - JBOOT bootloader Known issues: - WIFI 5G LED not working - flash is very slow The status led has been assigned to the dwr-118-a1:green:internet led. At the end of the boot it is switched off and is available for other operation. Work correctly also during sysupgrade operation. Installation: Apply factory image via http web-gui or JBOOT recovery page How to revert to OEM firmware: - push the reset button and turn on the power. Wait until LED start blinking (~10sec.) - upload original factory image via JBOOT http (IP: 192.168.123.254) Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index c526f9681e..143d33e3c8 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -176,6 +176,20 @@ define Device/dlink_dwr-116-a1
endef
TARGET_DEVICES += dlink_dwr-116-a1
+define Device/dlink_dwr-118-a1
+ DTS := DWR-118-A1
+ DEVICE_TITLE := D-Link DWR-118 A1
+ DEVICE_PACKAGES := kmod-usb2 jboot-tools kmod-mt76x0e
+ DLINK_ROM_ID := DLK6E3811001
+ DLINK_FAMILY_MEMBER := 0x6E38
+ DLINK_FIRMWARE_SIZE := 0xFE0000
+ KERNEL := $(KERNEL_DTB)
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
+ IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
+endef
+TARGET_DEVICES += dlink_dwr-118-a1
+
define Device/dlink_dwr-118-a2
DTS := DWR-118-A2
DEVICE_TITLE := D-Link DWR-118 A2