aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/mt7620.mk
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-03-10 01:28:28 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-03-11 22:00:26 +0100
commit9b6413982c4c7f9191d08995f1e9b67e38f259de (patch)
treeffeba0c46e3e405aaa7029dfe8dbafb99d505f98 /target/linux/ramips/image/mt7620.mk
parent6ac5144b13dd2c43f83deb715a9a2487f87d3c46 (diff)
downloadupstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.tar.gz
upstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.tar.bz2
upstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.zip
ramips: add support for ALFA Network Tube-E4G
ALFA Network Tube-E4G is an outdoor, dual-SIM LTE Cat. 4 CPE, based on MediaTek MT7620A, equipped with Quectel EC25 miniPCIe modem. Specification: - MT7620A (580 MHz) - 64/128/256 MB of RAM (DDR2) - 16/32 MB of flash (SPI NOR) - 1x 10/100 Mbps Ethernet, with passive PoE support (24 V) - 1x miniPCIe slot (with PCIe and USB 2.0 buses) - 2x SIM slot (mini, micro) with detect and switch driven by GPIO - 1x detachable antenna (modem main) - 1x internal antenna (modem div) - 1x GPS passive antenna (optional) - 5x LED (all driven by GPIO) - 1x button (reset) - UART (4-pin, 2.54 mm pitch) header on PCB Other: Default SIM slot is selected at an early stage by U-Boot, based on 'default_sim' environment value: 1 or unset = SIM1 (mini), 2 = SIM2 (micro). U-Boot also resets the modem, using #PERST signal, before starting kernel. Flash instruction: You can use the 'sysupgrade' image directly in vendor firmware which is based on OpenWrt (make sure to not preserve settings - use 'sysupgrade -n -F ...' command). Alternatively, use web recovery mode in U-Boot: 1. Power the device with reset button pressed, the LAN LED will start blinking slowly and after ~3 seconds, when it starts blinking faster, you can release the button. 2. Setup static IP 192.168.1.2/24 on your PC. 3. Go to 192.168.1.1 in browser and upload 'sysupgrade' image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/mt7620.mk')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 7ac228db16..77a5b5724d 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -51,6 +51,15 @@ define Device/alfa-network_ac1200rm
endef
TARGET_DEVICES += alfa-network_ac1200rm
+define Device/alfa-network_tube-e4g
+ DTS := TUBE-E4G
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := ALFA Network Tube-E4G
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools uqmi \
+ -iwinfo -kmod-rt2800-pci -kmod-rt2800-soc -wpad-basic
+endef
+TARGET_DEVICES += alfa-network_tube-e4g
+
define Device/Archer
TPLINK_HWREVADD := 0
TPLINK_HVERSION := 3