aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/lzma-loader/Makefile
diff options
context:
space:
mode:
authorAntonio Vázquez <antoniovazquezblanco@gmail.com>2023-01-21 22:34:28 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2023-04-29 22:32:27 +0200
commitc31319b66934f554f6c337b4cfa888b1fb74faa4 (patch)
treec360a304dbf66444d51c3487dcd1ae4c7ea6418b /target/linux/ramips/image/lzma-loader/Makefile
parente4c7703d2a62b8914e4723adae3f67c68a57532c (diff)
downloadupstream-c31319b66934f554f6c337b4cfa888b1fb74faa4.tar.gz
upstream-c31319b66934f554f6c337b4cfa888b1fb74faa4.tar.bz2
upstream-c31319b66934f554f6c337b4cfa888b1fb74faa4.zip
ramips: lzma-loader: Refactor loader
* Delete unused lantiq makefile * Delete redundant makefiles and unify them into the main makefile * Refactor and unify board code into a single file * Add support and review subtarget specific board support Signed-off-by: Antonio Vázquez <antoniovazquezblanco@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/lzma-loader/Makefile')
-rw-r--r--target/linux/ramips/image/lzma-loader/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ramips/image/lzma-loader/Makefile b/target/linux/ramips/image/lzma-loader/Makefile
index 4cf700d8c6..7b87941e02 100644
--- a/target/linux/ramips/image/lzma-loader/Makefile
+++ b/target/linux/ramips/image/lzma-loader/Makefile
@@ -18,6 +18,8 @@ FLASH_OFFS :=
FLASH_MAX :=
BOARD :=
PLATFORM :=
+SUBTARGET :=
+CACHE_FLAGS := -DCONFIG_CACHELINE_SIZE=32
ifeq ($(TARGET_DIR),)
TARGET_DIR := $(KDIR)
@@ -46,6 +48,8 @@ loader-compile: $(PKG_BUILD_DIR)/.prepared
FLASH_MAX=$(FLASH_MAX) \
BOARD="$(BOARD)" \
PLATFORM="$(PLATFORM)" \
+ SUBTARGET="$(SUBTARGET)" \
+ CACHE_FLAGS="$(CACHE_FLAGS)" \
clean all
loader.gz: $(PKG_BUILD_DIR)/loader.bin