aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/common-tp-link.mk
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-03-10 22:58:27 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-03-21 20:02:55 +0100
commit3f14f034fb5e191f4a537998379d8e922ec31e8a (patch)
tree2daa222bf570dcd278377f8fe4c8969a92d4ead0 /target/linux/ramips/image/common-tp-link.mk
parent1444e31a7bf54b796f8ef88e77fee255b959c6bb (diff)
downloadupstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.gz
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.tar.bz2
upstream-3f14f034fb5e191f4a537998379d8e922ec31e8a.zip
treewide: omit IMAGE_SIZE argument from check-size
Now that check-size uses IMAGE_SIZE by default, we can skip the argument from image recipes to reduce redundancy. Signed-off-by: Sungbo Eo <mans0n@gorani.run> [do not touch ar71xx] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/image/common-tp-link.mk')
-rw-r--r--target/linux/ramips/image/common-tp-link.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/image/common-tp-link.mk b/target/linux/ramips/image/common-tp-link.mk
index 587ef89fc1..07ad1ea250 100644
--- a/target/linux/ramips/image/common-tp-link.mk
+++ b/target/linux/ramips/image/common-tp-link.mk
@@ -12,7 +12,7 @@ define Device/tplink-v1
IMAGES += factory.bin
IMAGE/factory.bin := tplink-v1-image factory -e -O
IMAGE/sysupgrade.bin := tplink-v1-image sysupgrade -e -O | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
define Device/tplink-v2
@@ -27,7 +27,7 @@ define Device/tplink-v2
IMAGES += factory.bin
IMAGE/factory.bin := tplink-v2-image -e
IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata | \
- check-size $$$$(IMAGE_SIZE)
+ check-size
endef
define Device/tplink-safeloader
@@ -39,6 +39,6 @@ define Device/tplink-safeloader
KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
IMAGES += factory.bin
IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | \
- append-metadata | check-size $$$$(IMAGE_SIZE)
+ append-metadata | check-size
IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
endef