aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2021-06-10 17:17:23 +0200
committerPaul Spooren <mail@aparcar.org>2021-12-13 19:36:10 +0100
commit794e8123ce625d04f8207ba5fd3b153051b2e67e (patch)
tree7d668a85bdf96f7bf1079488c19f913f3effc338 /target/linux/ramips/image/Makefile
parent3bcf3e8143160e447c22c0ac3fa66fbcf6a59eef (diff)
downloadupstream-794e8123ce625d04f8207ba5fd3b153051b2e67e.tar.gz
upstream-794e8123ce625d04f8207ba5fd3b153051b2e67e.tar.bz2
upstream-794e8123ce625d04f8207ba5fd3b153051b2e67e.zip
ramips: mt7620: use OKLI loader with Jboot devices
Jboot devices have problem with >2MB kernelsize. The only way to avoid this problem is use small loader. This patch switch all mt7620 Jboot devices to lzma OKLI loader. Suggested-by: Szabolcs Hubai <szab.hu@gmail.com> Co-authored-by: Michael Pratt <mcpratt@pm.me> Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d523a62e0b..ac256cf1ae 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -89,6 +89,16 @@ define Build/mkdlinkfw-factory
mv $@.new $@
endef
+define Build/mkdlinkfw-loader
+ -$(STAGING_DIR_HOST)/bin/mkdlinkfw \
+ -k $(KDIR)/loader-$(DEVICE_NAME).bin \
+ -r $@ \
+ -o $@.new \
+ $(if $(DLINK_IMAGE_OFFSET), -O $(DLINK_IMAGE_OFFSET)) \
+ -s $(DLINK_FIRMWARE_SIZE)
+ mv $@.new $@
+endef
+
define Build/netis-tail
echo -n $(1) >> $@
echo -n $(UIMAGE_NAME)-yun | $(MKHASH) md5 | \