aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-11-25 13:03:01 +0100
committerMathias Kresin <dev@kresin.me>2016-11-27 15:34:23 +0100
commit6cc0ae27b90f73a547130be7b5b25ea576615dd6 (patch)
tree6b7f7f722b245cc57b9e7e0fe5c38d85dde5f5c4 /target/linux/ramips/image/Makefile
parent7cc0d8b3bdea8fcbf5ff36a0acceb652c152b507 (diff)
downloadupstream-6cc0ae27b90f73a547130be7b5b25ea576615dd6.tar.gz
upstream-6cc0ae27b90f73a547130be7b5b25ea576615dd6.tar.bz2
upstream-6cc0ae27b90f73a547130be7b5b25ea576615dd6.zip
ramips: fix Airlink AR670W factory image
Move the mkwrgimg build step to the makefile. It will be required by other boards as well. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 42cd63b7d7..25396f5984 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -99,6 +99,11 @@ define Build/seama-seal
$(call Build/seama,-s $@.seama $(1))
endef
+define Build/wrg-header
+ mkwrgimg -i $@ -d "/dev/mtdblock/2" -s $(1) -o $@.new
+ mv $@.new $@
+endef
+
#
# The real magic happens inside these templates
#