aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorAlan Luck <luckyhome2008@gmail.com>2021-04-20 19:44:01 +1000
committerDavid Bauer <mail@david-bauer.net>2021-09-24 12:32:28 +0200
commit2c9a07ed28e87bbe2d221d48aaa19b04672646a5 (patch)
treecbc9a4e4de214c8a1ac9426789e14840a6f4c13e /target/linux/ramips/image/Makefile
parent5269c47e8db549695ceaf6a19afdd0cb90074622 (diff)
downloadupstream-2c9a07ed28e87bbe2d221d48aaa19b04672646a5.tar.gz
upstream-2c9a07ed28e87bbe2d221d48aaa19b04672646a5.tar.bz2
upstream-2c9a07ed28e87bbe2d221d48aaa19b04672646a5.zip
ramips: add missing information to dlink headers
Add additional header information required for newer bootloaders found on DIR-2660-A1 & A2. Also remove the MTD splitter compatible from the second firmware partition, as OpenWrt only supports handling of the first one. Signed-off-by: Alan Luck <luckyhome2008@gmail.com> [rephrase commit message, remove removal of read-only flags] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 3671caef9d..d523a62e0b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -144,6 +144,12 @@ define Build/uimage-padhdr
mv $@.new $@
endef
+define Build/uimage-sgehdr
+ uimage_sgehdr -i $@ -o $@.new -m $(DEVICE_MODEL) \
+ -h $(DEVICE_VARIANT) -s V1.00000
+ mv $@.new $@
+endef
+
define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef