aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-03 09:43:31 +0200
committerMathias Kresin <dev@kresin.me>2016-09-03 09:43:31 +0200
commit0f3600cceef2cb47fda2a87efc24ab7eac84709f (patch)
tree659d68a6e84691130b3803e146ceb27dfaca8e2d /target/linux/ramips/image/Makefile
parent74da44cfc2a6d8d21a9eca0ae5dd1ef4069c1cef (diff)
downloadupstream-0f3600cceef2cb47fda2a87efc24ab7eac84709f.tar.gz
upstream-0f3600cceef2cb47fda2a87efc24ab7eac84709f.tar.bz2
upstream-0f3600cceef2cb47fda2a87efc24ab7eac84709f.zip
ramips: move seama build recipe to Makefile
The identical build step is defined twice. Move it to the parent Makefile to use only one version. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2af6d68547..39da5e09c0 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -83,6 +83,15 @@ define Build/senao-header
mv $@.new $@
endef
+define Build/seama
+ $(STAGING_DIR_HOST)/bin/seama -i $@ $(1)
+ mv $@.seama $@
+endef
+
+define Build/seama-seal
+ $(call Build/seama,-s $@.seama $(1))
+endef
+
#
# The real magic happens inside these templates
#