aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-11-17 13:02:26 +0100
committerFelix Fietkau <nbd@nbd.name>2016-11-19 11:24:10 +0100
commit478f1f6b167c6b1c91f5915e9567814350865c4c (patch)
tree7364b56ac1a97444c80d3a0f5245707989361f7e /target/linux/ramips/image/Makefile
parentbe296745f82665272771e1cfeb2c19438cf3cb5a (diff)
downloadupstream-478f1f6b167c6b1c91f5915e9567814350865c4c.tar.gz
upstream-478f1f6b167c6b1c91f5915e9567814350865c4c.tar.bz2
upstream-478f1f6b167c6b1c91f5915e9567814350865c4c.zip
ramips: append metadata to images
metadata checks are not enforced yet, because some images are still being built by legacy code Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index ea7ff7e92b..42cd63b7d7 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -37,7 +37,9 @@ define Device/Default
KERNEL := $(KERNEL_DTB) | uImage lzma
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
- IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+ SUPPORTED_DEVICES = $(1)
+ sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
define Build/patch-dtb