aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-06 04:52:07 +0000
committerJohn Crispin <john@openwrt.org>2014-10-06 04:52:07 +0000
commitb04bb3eea71338214ed83671f026e3e2625d23e8 (patch)
tree4c4369fcfa51a9951795dd86ba1b74349be6823a /target/linux/ramips/image/Makefile
parent7ab5357280ba8d15ebb9a7b1121a754b1c473fd1 (diff)
downloadupstream-b04bb3eea71338214ed83671f026e3e2625d23e8.tar.gz
upstream-b04bb3eea71338214ed83671f026e3e2625d23e8.tar.bz2
upstream-b04bb3eea71338214ed83671f026e3e2625d23e8.zip
ramips: Support for RAMIPS based Tripmate HT-TM02 board
Provides support for the Tripmate HT-TM02 personal router including LEDs and reset button. “Mode” switch is not supported. New profile includes full set of packages required to enable LEDs, USB, and LUCI. Patches were applied against trunk snapshot r42649. Functionality has been tested in AP, basic wifi client, wifi router, and routed client modes - all good. Signed-off-by: Ron Curry <wingspinner@gmail.com> SVN-Revision: 42785
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 35057e49e4..c365d9dbb5 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -434,6 +434,8 @@ define BuildFirmware/HLKRM04/initramfs
endef
Image/Build/Profile/HLKRM04=$(call BuildFirmware/HLKRM04/$(1),$(1),hlk-rm04,HLKRM04,HLK-RM02)
+Image/Build/Profile/HT-TM02=$(call BuildFirmware/Default8M/$(1),$(1),ht-tm02,HT-TM02)
+
Image/Build/Profile/M3=$(call BuildFirmware/Poray4M/$(1),$(1),m3,M3)
Image/Build/Profile/M4=$(call BuildFirmware/PorayDualSize/$(1),$(1),m4,M4)
@@ -598,6 +600,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/FREESTATION5,$(1))
# $(call Image/Build/Profile/HG255D,$(1))
$(call Image/Build/Profile/HLKRM04,$(1))
+ $(call Image/Build/Profile/HT-TM02,$(1))
$(call Image/Build/Profile/HW550-3G,$(1))
$(call Image/Build/Profile/IP2202,$(1))
$(call Image/Build/Profile/M3,$(1))