aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorFUKAUMI Naoki <naobsd@gmail.com>2017-01-29 01:05:56 +0900
committerRafał Miłecki <rafal@milecki.pl>2017-01-31 11:10:58 +0100
commit6b0b526a4fc11d3b1b588d5b3b789da0c66adce9 (patch)
tree1ad589aba17e5ec3f9b14dc18c3b3e6afe02e41a /target/linux/ramips/image/Makefile
parent3b5d29b96e4df80dbfbcc5bbb8a5898a9390c683 (diff)
downloadupstream-6b0b526a4fc11d3b1b588d5b3b789da0c66adce9.tar.gz
upstream-6b0b526a4fc11d3b1b588d5b3b789da0c66adce9.tar.bz2
upstream-6b0b526a4fc11d3b1b588d5b3b789da0c66adce9.zip
ramips: add support for Buffalo WCR-1166DS
Buffalo WCR-1166DS is a small wireless router with - MT7628AN + MT7612E - 64MiB DDR2 SDRAM - 16MiB SPI flash - 2T2R 11ac/a/b/g/n Wi-Fi - 2x 10/100M ethernet switch - 8x programmable LED - 3x button - UART pad on PCB (J2: 3.3V, GND, TX, RX) factory image can be installed via stock web UI. due to the "dual image" function in the bootloader, the second half of the SPI flash ("firmware2" partition) cannot be used as a part of the file system. Signed-off-by: FUKAUMI Naoki <naobsd@gmail.com>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2952c5f840..f34eba79cd 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -23,6 +23,7 @@ define Image/Build/Initramfs
endef
DEVICE_VARS += DTS IMAGE_SIZE NETGEAR_BOARD_ID NETGEAR_HW_ID
+DEVICE_VARS += BUFFALO_TAG_PLATFORM BUFFALO_TAG_VERSION BUFFALO_TAG_MINOR
loadaddr-y := 0x80000000
loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
@@ -48,7 +49,7 @@ define Build/patch-dtb
endef
define Build/trx
- $(STAGING_DIR_HOST)/bin/trx \
+ $(STAGING_DIR_HOST)/bin/trx $(1) \
-o $@ \
-m $(IMAGE_SIZE) \
-f $(IMAGE_KERNEL) \