aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-27 07:38:08 +0200
committerMathias Kresin <dev@kresin.me>2016-10-15 09:01:45 +0200
commite7ec5df33bdb3929c1b99adb68813643cc6ecd25 (patch)
treef3df6582fbe1b308e8c8cf063359f6ffd8604814 /target/linux/ramips/image/Makefile
parent634d690d740ad2e586701a393d60cc9753808193 (diff)
downloadupstream-e7ec5df33bdb3929c1b99adb68813643cc6ecd25.tar.gz
upstream-e7ec5df33bdb3929c1b99adb68813643cc6ecd25.tar.bz2
upstream-e7ec5df33bdb3929c1b99adb68813643cc6ecd25.zip
ramips: move edimax images to the new build code
Images installed via TFTP recovery or the Edimax webinterface of the 3g-6200n(l) are writting with the edimax header to flash. Use only one image type for these boards. The migration to the factory only images need to be done via TFTP recovery. Use the same start address for the 3g-6200n(l) factory images as the stock firmware images. Thanks to Jan Dostrasil for reporting all the issues of the 3g-6200nl and the patient testing of all changes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index d165ec5512..ea7ff7e92b 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -78,6 +78,11 @@ define Build/umedia-header
fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
endef
+define Build/edimax-header
+ $(STAGING_DIR_HOST)/bin/mkedimaximg -i $@ -o $@.new $(1)
+ @mv $@.new $@
+endef
+
define Build/senao-header
$(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
mv $@.new $@