aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-07-06 08:04:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-07-06 08:04:54 +0000
commit4acf79169e66d5551fa9095ce9ea22a6b08c0f5f (patch)
tree4b7f8d144485729c81b3035c157cc3fe2fbc57a2 /target/linux/ramips/image/Makefile
parent6780ee387da66cbb34d043b3e3139c57ff0cf733 (diff)
downloadupstream-4acf79169e66d5551fa9095ce9ea22a6b08c0f5f.tar.gz
upstream-4acf79169e66d5551fa9095ce9ea22a6b08c0f5f.tar.bz2
upstream-4acf79169e66d5551fa9095ce9ea22a6b08c0f5f.zip
ramips: create tftp image for the WHR-G300N board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27476 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/image/Makefile')
-rw-r--r--target/linux/ramips/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 2a841efce8..042c319af7 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -129,6 +129,13 @@ mtdlayout_whrg300n=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k
define Image/Build/Profile/WHRG300N
$(call Image/Build/Template/GENERIC_4M,$(1),whr-g300n,WHR-G300N)
$(call BuildFirmware/Buffalo,$(1),whr-g300n,WHR-G300N,mtdlayout_whrg300n,983040,3801088)
+ ( \
+ echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
+ dd bs=512 count=1 conv=sync; \
+ dd if=$(call imgname,$(1),whr-g300n)-sysupgrade.bin; \
+ ) > $(KDIR)/whr-g300n-tftp.tmp
+ buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
+ -o $(call imgname,$(1),whr-g300n)-tftp.bin
endef
define Image/Build/Profile/HW5503G