aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-09 14:09:48 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-12 22:27:17 +0800
commit33d027c5b8fb5265ea84ac41a7bfedd805c48b24 (patch)
tree81e9e97d1700c47db77ee6c592ac836ad1f669b6 /target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
parentb0ec8d0ca0713113a0384bd74b560bd17c298712 (diff)
downloadupstream-33d027c5b8fb5265ea84ac41a7bfedd805c48b24.tar.gz
upstream-33d027c5b8fb5265ea84ac41a7bfedd805c48b24.tar.bz2
upstream-33d027c5b8fb5265ea84ac41a7bfedd805c48b24.zip
ramips: move and rename out-of-tree mtk eth driver
move the driver into shared 'files' directory and rename all symbols from mediatek/mtk to ralink. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile')
-rw-r--r--target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
new file mode 100644
index 0000000000..eba21643b2
--- /dev/null
+++ b/target/linux/ramips/files/drivers/net/ethernet/ralink/Makefile
@@ -0,0 +1,22 @@
+#
+# Makefile for the Ralink SoCs built-in ethernet macs
+#
+
+ralink-eth-y += mtk_eth_soc.o ethtool.o
+
+ralink-eth-$(CONFIG_NET_RALINK_MDIO) += mdio.o
+ralink-eth-$(CONFIG_NET_RALINK_MDIO_RT2880) += mdio_rt2880.o
+ralink-eth-$(CONFIG_NET_RALINK_MDIO_MT7620) += mdio_mt7620.o
+
+ralink-eth-$(CONFIG_NET_RALINK_OFFLOAD) += mtk_offload.o mtk_debugfs.o
+
+ralink-eth-$(CONFIG_NET_RALINK_RT2880) += soc_rt2880.o
+ralink-eth-$(CONFIG_NET_RALINK_RT3050) += soc_rt3050.o
+ralink-eth-$(CONFIG_NET_RALINK_RT3883) += soc_rt3883.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7620) += soc_mt7620.o
+ralink-eth-$(CONFIG_NET_RALINK_MT7621) += soc_mt7621.o
+
+obj-$(CONFIG_NET_RALINK_ESW_RT3050) += esw_rt3050.o
+obj-$(CONFIG_NET_RALINK_GSW_MT7620) += gsw_mt7620.o mt7530.o
+obj-$(CONFIG_NET_RALINK_GSW_MT7621) += gsw_mt7621.o mt7530.o
+obj-$(CONFIG_NET_RALINK_SOC) += ralink-eth.o