aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2018-03-23 13:42:56 +0100
committerFelix Fietkau <nbd@nbd.name>2018-04-06 19:37:53 +0200
commit424a9ae128bd2045cd4bfd6e3229f2529d150a25 (patch)
tree2d82652a341a08c3edb660893c20315d5cafc41e /target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile
parentdea9922acd290b37a784d354892a44684a8fb696 (diff)
downloadupstream-424a9ae128bd2045cd4bfd6e3229f2529d150a25.tar.gz
upstream-424a9ae128bd2045cd4bfd6e3229f2529d150a25.tar.bz2
upstream-424a9ae128bd2045cd4bfd6e3229f2529d150a25.zip
ramips: implement hardware NAT offload for MT7621
Supports IPv4 flow offloading on MT7621 for Routing, SNAT and DNAT Supported are regular ethernet->ethernet connections, including one 802.1q VLAN and/or PPPoE encapsulation Signed-off-by: John Crispin <john@phrozen.org> Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile')
-rw-r--r--target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile b/target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile
index 07ba4c2ecf..b038ae3699 100644
--- a/target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile
+++ b/target/linux/ramips/files-4.14/drivers/net/ethernet/mtk/Makefile
@@ -8,6 +8,8 @@ mtk-eth-soc-$(CONFIG_NET_MEDIATEK_MDIO) += mdio.o
mtk-eth-soc-$(CONFIG_NET_MEDIATEK_MDIO_RT2880) += mdio_rt2880.o
mtk-eth-soc-$(CONFIG_NET_MEDIATEK_MDIO_MT7620) += mdio_mt7620.o
+mtk-eth-soc-$(CONFIG_NET_MEDIATEK_OFFLOAD) += mtk_offload.o mtk_debugfs.o
+
mtk-eth-soc-$(CONFIG_NET_MEDIATEK_RT2880) += soc_rt2880.o
mtk-eth-soc-$(CONFIG_NET_MEDIATEK_RT3050) += soc_rt3050.o
mtk-eth-soc-$(CONFIG_NET_MEDIATEK_RT3883) += soc_rt3883.o