aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 09:58:44 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 09:58:44 +0000
commitd4db00205d726f9faca3147cb345518ec5406aab (patch)
tree2e4466b8176c978c765dfeac1ea5f6ab5a0a203a /target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
parent86a691144b4988d2ebfb78834b608dec51b53a33 (diff)
downloadupstream-d4db00205d726f9faca3147cb345518ec5406aab.tar.gz
upstream-d4db00205d726f9faca3147cb345518ec5406aab.tar.bz2
upstream-d4db00205d726f9faca3147cb345518ec5406aab.zip
move files to files-3.7
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36161
Diffstat (limited to 'target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile')
-rw-r--r--target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile b/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
new file mode 100644
index 0000000000..95c5b66fea
--- /dev/null
+++ b/target/linux/ramips/files-3.7/drivers/usb/dwc_otg/Makefile
@@ -0,0 +1,25 @@
+#
+# Makefile for DWC_otg Highspeed USB controller driver
+#
+
+ifeq ($(CONFIG_DWC_OTG_DEBUG),y)
+EXTRA_CFLAGS += -DDEBUG
+endif
+
+# Use one of the following flags to compile the software in host-only or
+# device-only mode.
+ifeq ($(CONFIG_DWC_OTG_HOST_ONLY),y)
+EXTRA_CFLAGS += -DDWC_HOST_ONLY
+EXTRA_CFLAGS += -DDWC_EN_ISOC
+endif
+
+ifeq ($(CONFIG_DWC_OTG_DEVICE_ONLY),y)
+EXTRA_CFLAGS += -DDWC_DEVICE_ONLY
+endif
+
+obj-$(CONFIG_DWC_OTG) := dwc_otg.o
+
+dwc_otg-objs := dwc_otg_driver.o dwc_otg_attr.o
+dwc_otg-objs += dwc_otg_cil.o dwc_otg_cil_intr.o
+dwc_otg-objs += dwc_otg_pcd.o dwc_otg_pcd_intr.o
+dwc_otg-objs += dwc_otg_hcd.o dwc_otg_hcd_intr.o dwc_otg_hcd_queue.o